Bug 501920 - [ibus][Indic] - ibus Malfunctioning when conflict with keyboard-indicator
[ibus][Indic] - ibus Malfunctioning when conflict with keyboard-indicator
Status: CLOSED DUPLICATE of bug 500732
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 06:22 EDT by Satyabrata Maitra
Modified: 2009-08-16 23:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 04:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satyabrata Maitra 2009-05-21 06:22:41 EDT
Description of problem:
When Keyboard Indicator is enabled with any locale other than USA, at that time if you select ibus for any layout, it will not work with ibus, it works with keyboard-indicator at that time. 

Moreover that, when any other layout engine is enabled in the system, if at that time user enable ibus, the application should show Warning message indicating that other engine is enable which may restrict ibus to work properly.

Version-Release number of selected component (if applicable):

ibus-1.1.0.20090423-1.fc11.i586
ibus-gtk-1.1.0.20090423-1.fc11.i586
keyboard indicator 2.26.1

How reproducible:
Always

Steps to Reproduce:
1. Switch on keyboard Indicator with any layout except USA
2. Switch on ibus with any layout.
3. Open any editor, gedit
4. Try to type according to ibus's layout.
5. Observe the result.
  
Actual results:
It will always follow the layout enabled in keyboard Indicator, and when enable ibus, it will not show any warning message that other engine is already enabled.

Expected results:
ibus should always detect if any other same engine is already enabled in the system and behave accordingly.

Additional info:
Comment 1 Jens Petersen 2009-05-24 22:15:18 EDT
This related to bug 500732: problem is it does not affect all input methods only those that are key-position based.
Comment 2 Peng Huang 2009-06-02 05:46:11 EDT
I implemented keymap in ibus. With keymap, ibus processes scan code instead of keysym. I think it could fix your problem. Please try the scratch build of ibus.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1389096
Comment 3 Bug Zapper 2009-06-09 12:14:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Peng Huang 2009-06-15 04:57:53 EDT
This problem is because ibus conflicts with xkb. If user does not set correct xkb layout, ibus will not work correctly. It is like bug 500732

*** This bug has been marked as a duplicate of bug 500732 ***
Comment 5 Jens Petersen 2009-08-16 23:00:25 EDT
I think it would be better to make gnome keyboard switcher and ibus
applets exclusive or better still to merge them somehow.

Note You need to log in before you can comment on or make changes to this bug.