Bug 502007 - pvremove, vgremove, lvremove tests/commands sometimes fail
pvremove, vgremove, lvremove tests/commands sometimes fail
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 10:34 EDT by Richard W.M. Jones
Modified: 2009-05-21 11:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 11:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log from failed tests (72 bytes, text/plain)
2009-05-21 10:34 EDT, Richard W.M. Jones
no flags Details
build.log from failed tests (1.42 MB, text/plain)
2009-05-21 10:36 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2009-05-21 10:34:09 EDT
Created attachment 344970 [details]
build.log from failed tests

During tests, particularly on Koji, the tests
associated with these commands will
sometimes fail.

The 'make check' will display something
like this:

 32/140 test_pvremove_0
test_pvremove_0 FAILED
 33/140 test_pvremove_1
test_pvremove_1 FAILED
 34/140 test_pvremove_2
test_pvremove_2 FAILED
 35/140 test_vgremove_0
test_vgremove_0 FAILED
 36/140 test_vgremove_1
test_vgremove_1 FAILED
 37/140 test_lvremove_0
test_lvremove_0 FAILED
 38/140 test_lvremove_1
test_lvremove_1 FAILED
 39/140 test_lvremove_2
test_lvremove_2 FAILED
Comment 1 Richard W.M. Jones 2009-05-21 10:36:34 EDT
Created attachment 344972 [details]
build.log from failed tests
Comment 2 Richard W.M. Jones 2009-05-21 10:41:12 EDT
The error message is:

/sbin/lvm pvcreate /dev/sda
guestfsd: error: File descriptor 3 (socket:[12577]) leaked on lvm invocation. Parent PID 1: 
  Device /dev/sda not found (or ignored by filtering).

I suspect what is happening here is that because
/dev/sda is partitioned, pvcreate really wants to
refuse to create a PV on top of the partition table.
The tests should be changed so that they create the
PV on /dev/sda1.
Comment 3 Richard W.M. Jones 2009-05-21 11:19:32 EDT
This should be fixed by upstream changeset
2a042d9844ca203ccea28a5d533c18f2dbdfcfa7.

Note You need to log in before you can comment on or make changes to this bug.