Bug 502091 - Multiple rawhide yum repo's displayed in reposetup
Multiple rawhide yum repo's displayed in reposetup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 16:01 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 16:43:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installer-repos.tar (10.00 KB, application/octet-stream)
2009-05-22 16:25 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-05-21 16:01:08 EDT
Description of problem:

During the reposetup install screen, I see 2 repos that seem to both reference rawhide. 

 * Fedora - Rawhide - Developmental packages for the next Fedora release
 * Fedora development - x86_64

The repourl's differ for the the two entries (rawhide vs develoment), but they essentially both point to rawhide righT?

Version-Release number of selected component (if applicable):

 * anaconda-11.5.0.54

Steps to Reproduce:
1. PXE boot rawhide with method=
2. Proceed through installation to reposetup screen
  
Actual results:

 * http://jlaska.fedorapeople.org/Screenshot.png

Expected results:

 * I could be wrong, but the repo's listed seem different.  THe 2nd and 3rd repo's listed seem to both point to rawhide.  Is that right?


Additional info:
Comment 1 Chris Lumens 2009-05-22 13:16:06 EDT
What has enabled=1 in /etc/anaconda.repos.d/* ?
Comment 2 James Laska 2009-05-22 16:25:33 EDT
Created attachment 345160 [details]
installer-repos.tar

(In reply to comment #1)
> What has enabled=1 in /etc/anaconda.repos.d/* ?  

Looks like /etc/anaconda.repos.d/fedora-updates.repo [updates] and /etc/anaconda.repos.d/fedora.repo-[fedora]
Comment 3 Bill Nottingham 2009-05-29 00:03:21 EDT
Does this persist with RC images?
Comment 4 James Laska 2009-05-29 08:20:09 EDT
Sure does(In reply to comment #3)
> Does this persist with RC images?  

Yes
Comment 5 Bill Nottingham 2009-05-29 10:21:46 EDT
Sorry, probably should have asked for more info. Does it happen with both media and network installs?
Comment 6 James Laska 2009-05-29 14:11:42 EDT
Looks like booting and installing from the RC2 x86_64 DVD (tested both i386 and x86_64) shows the correct repos:

* Installation Repo
* Fedora - Rawhide -Development packages for the next fedora release
* Fedora 11 - x86_64
* Fedora 11 - x86_64 - Test Updates
* Fedora 11 - x86_64 - Updates

However when booting and installing from rawhide, I see duplicate repos.

* Installation Repo
* Fedora - Rawhide -Development packages for the next fedora release
* Fedora development - x86_64
* Fedora development - x86_64 - Test Updates
* Fedora development - x86_64 - Updates

Seeing the two sets side-by-side shows that there's no difference other than the version of '11' vs 'development'.  So just a minor nit with this bug more than anything else.
Comment 7 Bill Nottingham 2009-05-29 14:39:40 EDT
I think this is just the difference in how rawhide is composed. CC'ing Jesse.
Comment 8 Jesse Keating 2009-05-29 16:35:04 EDT
Yes, when we compose rawhide, pungi is called with a version of development, whereas when making the release, we call it with a version of the release.
Comment 9 James Laska 2009-05-29 16:43:29 EDT
Gotcha, so I guess this is more just NOTABUG.  It just looked funny, but given it isn't present when doing F11 RC installs, but I don't see anything needing to be "fixed" here.

Note You need to log in before you can comment on or make changes to this bug.