Bug 502115 - [KVM] Fedora11 Rawhide: Segfault in libvirtd
[KVM] Fedora11 Rawhide: Segfault in libvirtd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
x86_64 All
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-21 18:41 EDT by IBM Bug Proxy
Modified: 2009-06-04 09:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 09:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fc11 guest log file (57.21 KB, text/plain)
2009-05-21 18:41 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 53464 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-05-21 18:41:03 EDT
=Comment: #0=================================================
PAVAN NAREGUNDI <pavan.naregundi@in.ibm.com> - 

fc11 guest log file

While trying start the fc11 rawhide guest with virsh gave a segfault and virsh got disconnected below

=========
virsh # dominfo fc11
Id:             -
Name:           fc11
UUID:           2df2a274-12aa-7b49-7714-a588f9e4493d
OS Type:        hvm
State:          shut off
CPU(s):         1
Max memory:     524288 kB
Used memory:    524288 kB
Autostart:      disable
error: server closed connection

virsh # start fc11
# dmesg
libvirtd[1681]: segfault at 0 ip 00007f3045b68411 sp 00007f304217dbc8 error 4 in libc-2.10.1.so
(deleted)[7f3045ae9000+164000]
==========================

libvirtd daemon got killed after this.

Guest OS: Fedora11 Rawhide
Host: Fedora11 Rawhide
=Comment: #1=================================================
PAVAN NAREGUNDI <pavan.naregundi@in.ibm.com> - 
virsh # version 
Compiled against library: libvir 0.6.2
Using library: libvir 0.6.2
Using API: QEMU 0.6.2
Running hypervisor: QEMU 0.10.1

virsh #
Comment 1 IBM Bug Proxy 2009-05-21 18:41:12 EDT
Created attachment 345040 [details]
fc11 guest log file
Comment 2 Mark McLoughlin 2009-05-25 11:46:19 EDT
Please use "rpm -q virt-manager python-virtinst libvirt qemu-system-x86" to let us know exactly what versions you are using

I can't reproduce this here, could you try again with the latest libvirt and qemu from updates-testing ?

  https://admin.fedoraproject.org/updates/libvirt-0.6.2-11.fc11
  https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5050

If you can reproduce this it would be good to get a log from libvirtd using the instructions from here:

  https://fedoraproject.org/wiki/Reporting_virtualization_bugs#libvirt
Comment 3 IBM Bug Proxy 2009-05-27 03:00:35 EDT
------- Comment From pavan.naregundi@in.ibm.com 2009-05-27 02:54 EDT-------
(In reply to comment #8)
> Please use "rpm -q virt-manager python-virtinst libvirt qemu-system-x86" to let
> us know exactly what versions you are using
>

virt-manager-0.7.0-4.fc11.x86_64
python-virtinst-0.400.3-8.fc11.noarch
libvirt-0.6.2-8.fc11.x86_64
qemu-system-x86-0.10-16.fc11.x86_64

> I can't reproduce this here, could you try again with the latest libvirt and
> qemu from updates-testing ?
>
> https://admin.fedoraproject.org/updates/libvirt-0.6.2-11.fc11
> https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5050
>

Updated the qemu and libvirt. Could not reproduce it now.

> If you can reproduce this it would be good to get a log from libvirtd using the
> instructions from here:
>
> https://fedoraproject.org/wiki/Reporting_virtualization_bugs#libvirt
>

Thanks
Pavan
Comment 4 Mark McLoughlin 2009-06-04 09:42:51 EDT
(In reply to comment #3)
> 
> Updated the qemu and libvirt. Could not reproduce it now.

Thanks, closing.

Note You need to log in before you can comment on or make changes to this bug.