Bug 50212 - nautilus doesn't start on any display besides :0
nautilus doesn't start on any display besides :0
Status: CLOSED DUPLICATE of bug 50580
Product: Red Hat Raw Hide
Classification: Retired
Component: fam (Show other bugs)
1.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-28 01:57 EDT by Ed McKenzie
Modified: 2007-03-26 23:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-10 11:02:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-07-28 01:57:22 EDT
nautilus-1.0.4.1-1 fails to start on any display besides :0.  This is
easily reproduced; change the default display number in gdm.conf, and
nautilus will hang on every login before it even displays anything.  It
seems to get stuck waiting for select() ...
Comment 1 Havoc Pennington 2001-08-01 17:48:27 EDT
Works for me if I add a display in gdm, or change the only display to 1. Maybe
my interpretation of "change the default display number" is different from yours? 
Exactly what is the line in gdm.conf that you have?
Comment 2 Ed McKenzie 2001-08-01 19:21:48 EDT
If I create a new profile and run startx -- :1, nautilus won't start; if I
strace it from the console, it seems to hang on a select call (lots of strings
beginning with 'GIOP' are being read() at the time, if that's useful info.)

The same profile starts nautilus flawlessly every time on :0.

This is all with nautilus-1.0.4.1-1.
Comment 3 Ed McKenzie 2001-08-01 19:22:45 EDT
I should add that having a display running on :0 doesn't seem to affect how
nautilus behaves on other displays.
Comment 4 Havoc Pennington 2001-08-02 14:13:14 EDT
Where did you get nautilus-1.0.4.1-1? Our current is nautilus-1.0.4-25.
Does it happen with whatever is latest in rawhide?
Comment 5 Ed McKenzie 2001-08-02 17:59:06 EDT
nautilus-1.0.4.1-1 was from rawhide (18 july 2001.)

i'll do a clean install of roswell this weekend and see if that fixes it.
Comment 6 Ed McKenzie 2001-08-04 18:08:50 EDT
Roswell fixed it.  Thanks
Comment 7 Ed McKenzie 2001-08-04 20:39:20 EDT
Actually, I lied -- it's still broken.  If I create users A, B, and C and log in
simultaneously on :0, :1, and :2, nautilus only starts on :0.  Each user's
profile works properly when logged in on :0.
Comment 8 Owen Taylor 2001-08-10 11:02:32 EDT
The multiple-users thing is a fam problem. Alex was looking into that,
so I've assigned him the bug.
Comment 9 Alexander Larsson 2001-08-10 11:37:44 EDT

*** This bug has been marked as a duplicate of 50580 ***

Note You need to log in before you can comment on or make changes to this bug.