Bug 502128 - /etc/init.d/multipathd reports error for non-dm managed root disk
/etc/init.d/multipathd reports error for non-dm managed root disk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: 5.4
Assigned To: Ben Marzinski
Cluster QE
:
: 527727 557699 (view as bug list)
Depends On:
Blocks: 554561
  Show dependency treegraph
 
Reported: 2009-05-21 21:49 EDT by Lachlan McIlroy
Modified: 2015-04-12 19:14 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 554561 (view as bug list)
Environment:
Last Closed: 2010-03-30 04:31:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to suppress dmsetup error (663 bytes, patch)
2009-05-21 21:49 EDT, Lachlan McIlroy
no flags Details | Diff

  None (edit)
Description Lachlan McIlroy 2009-05-21 21:49:56 EDT
Created attachment 345046 [details]
patch to suppress dmsetup error

When the root device isn't a logical device managed by the device-mapper driver dmsetup in stop() of the multipath init script

       dm_num=`dmsetup info -c --noheadings -o minor $root_dev`

returns "dm_task_set_name: Device /dev/cciss/c0d0p1 not found"

[root@dl585g2 ~]# /etc/init.d/multipathd restart
dm_task_set_name: Device /dev/cciss/c0d0p1 not found
Command failed
Stopping multipathd daemon:                                [  OK  ]
Starting multipathd daemon:                                [  OK  ]
Comment 2 Lachlan McIlroy 2009-06-02 23:16:05 EDT
To reproduce this issue:

1. Start an installation of RHEL5
2. In the disk partitioning stage select "Create custom layout"
3. Create partitions for /boot, swap and / and turn on
   the "force to be a primary partition" flag for each one.
4. Finish the installation and boot the system
5. Execute '/etc/init.d/multipathd restart' and the error
   message will be reported.
Comment 5 Ben Marzinski 2009-08-31 18:03:31 EDT
Patch applied.

I changed

dmsetup info -c --noheadings -o minor $root_dev >& /dev/null

to

dmsetup info -c --noheadings -o minor $root_dev 2> /dev/null

"2>" redirects stderr to /dev/null, which I believe is the intention.
Comment 6 Ben Marzinski 2009-10-08 16:50:54 EDT
*** Bug 527727 has been marked as a duplicate of this bug. ***
Comment 8 michal novacek 2010-01-08 11:04:22 EST
# mount
/dev/vda3 on / type ext3 (rw)
...

--device-mapper-multipath-0.4.7-17.el5
# service multipathd restart
Device /dev/vda3 not found
Command failed
Stopping multipathd daemon:                                [FAILED]
Starting multipathd daemon:                                [  OK  ]

--device-mapper-multipath-0.4.7-31.el5
# service multipathd restart
Stopping multipathd daemon:                                [  OK  ]
Starting multipathd daemon:                                [  OK  ]
Comment 11 Ben Marzinski 2010-01-25 13:01:04 EST
*** Bug 557699 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2010-03-30 04:31:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0255.html

Note You need to log in before you can comment on or make changes to this bug.