Bug 502148 - Epiphany web browser cannot be installed due to a missing dependency on gecko-libs.
Epiphany web browser cannot be installed due to a missing dependency on gecko...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 05:15 EDT by Greg Harvey
Modified: 2009-05-26 06:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 06:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Harvey 2009-05-22 05:15:33 EDT
Description of problem:

Cannot install Epiphany from yum because of a dependency on non-existent package, gecko-libs = 1.9.0.4.

Version-Release number of selected component (if applicable):

epiphany-2.24.1-2.fc10.i386 (fedora)

How reproducible:

Does it every time on my laptop. Have no other Fedora 10 machine to test with.

Steps to Reproduce:
1. Open Add/Remove software in the Gnome GUI
2. Search for "epiphany"
3. In resulting list check epiphany-2.24.1-2.fc10.i386 (fedora), GNOME web browser based on the Mozilla rendering engine
4. Click Apply
  
Actual results:

Dependency resolution failed:

gecko-libs = 1.9.0.4 is needed by package epiphany-2.24.1-2.fc10.i386 (fedora)

Expected results:

Epiphany installs and I get to try it out! =)

Additional info:

A bit of reading indicates that perhaps gecko-libs is already available as a part of a Firefox dependency, xulrunner-1.9.0.4-1.fc10.i386, but Epiphany doesn't seem to know this so refuses to install!
Comment 1 Matěj Cepl 2009-05-23 12:42:36 EDT
What is the output of

repoquery -q --provides xulrunner |grep gecko

on your computer? (repoquery is from yum-utils package)
Comment 2 Greg Harvey 2009-05-25 14:37:42 EDT
Hmmm, it says:

$ repoquery -q --provides xulrunner |grep gecko
gecko-libs = 1.9.0.10

HTH! =)
Comment 3 Matěj Cepl 2009-05-26 06:07:36 EDT
Probably epiphany needs to be rebuilt.
Comment 4 Martin Stransky 2009-05-26 06:17:24 EDT
fixed in epiphany-2.24.3-6.fc10.i386

Note You need to log in before you can comment on or make changes to this bug.