Bug 502150 - [PATCH] libcryptsetup interface enhancements
[PATCH] libcryptsetup interface enhancements
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Milan Broz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 05:20 EDT by Miloslav Trmač
Modified: 2013-02-28 23:07 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-18 05:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add direct master key access to libcryptsetup. (21.56 KB, patch)
2009-05-22 05:20 EDT, Miloslav Trmač
no flags Details | Diff

  None (edit)
Description Miloslav Trmač 2009-05-22 05:20:39 EDT
Created attachment 345070 [details]
Add direct master key access to libcryptsetup.

The attached patch adds:

* crypt_luks_get_volume_info () and related functions, that allow
  reading volume metadata more cleanly than attempting to parse the
  output of crypt_luksDump ().
* Four functions that allow direct manipulation of the master key,
  necessary for automated master key backup.
* Minor Makefile changes to fix build when builddir != srcdir.

The patch is necessary for https://fedorahosted.org/volume_key/ .  I have sent it upstream, filing here as well so it doesn't get lost.
Comment 1 Milan Broz 2009-05-22 05:57:31 EDT
Is that patch accepted by upstream maintainer? (I mean ack for design, not commit in svn.)
Comment 2 Miloslav Trmač 2009-05-22 06:16:38 EDT
I haven't received any response so far.
Comment 3 Bug Zapper 2009-06-09 12:19:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Milan Broz 2009-09-18 05:59:58 EDT
The new libbcryptsetup library with master key acces interface is in rawhide already (cryptsetup-lib-1.1.*).

I do not plan this update for F11 because of library soname change.

Note You need to log in before you can comment on or make changes to this bug.