Bug 502172 - No /dev/disk/by-id/* nodes for CCISS logical volumes
No /dev/disk/by-id/* nodes for CCISS logical volumes
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: udev (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 06:26 EDT by Tomas Smetana
Modified: 2011-10-15 17:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-15 17:19:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed udev rules change. (938 bytes, patch)
2009-05-22 06:27 EDT, Tomas Smetana
no flags Details | Diff

  None (edit)
Description Tomas Smetana 2009-05-22 06:26:33 EDT
Description of problem:
On a system with CCISS controllers there are no /dev/disk/by-id/* nodes fore the /dev/cciss/c*d* devices.  Only the per partition UUID symlinks are being created.  Usage of the symlinks is however recommended for setting up the raw devices in the installation documentation of a certain database software...

Version-Release number of selected component (if applicable):
udev-095-14.21.el5

How reproducible:
always

Steps to Reproduce:
1. Boot a system with logical disks on CCISS controller
2. ls -l /dev/disk/by-id
  
Actual results:
ls: /dev/disk/by-id/: No such file or directory

Expected results:
Something like

total 0
lrwxrwxrwx 1 root root 16 May 22 10:48 cciss-3600508b1001fffffa00f232e41ca9403 -> ../../cciss/c0d0
lrwxrwxrwx 1 root root 16 May 22 10:48 cciss-3600508b1001fffffa00f34e649379404 -> ../../cciss/c0d1


Additional info:
Since there has been the "-n" option added in the recent release, we should make an use of it in the udev rules.  Adding the following line to /etc/udev/rules.d/50-udev.rules seems to fix the issue:

KERNEL=="cciss?c[0-9]d[0-9]", ENV{ID_SERIAL}=="", ENV{ID_BUS}="cciss", IMPORT{program}="scsi_id -g -x -n -a -s %p", SYMLINK+="disk/by-id/$env{ID_BUS}-$env{ID_SERIAL}"
Comment 1 Tomas Smetana 2009-05-22 06:27:44 EDT
Created attachment 345075 [details]
Proposed udev rules change.
Comment 6 RHEL Product and Program Management 2009-11-06 14:24:03 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Note You need to log in before you can comment on or make changes to this bug.