Bug 50218 - HP LaserJet 1200 doesn't work with USB
Summary: HP LaserJet 1200 doesn't work with USB
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brock Organ
URL: http://www.geocrawler.com/mail/msg.ph...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-28 15:07 UTC by Aleksey Nogin
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-18 23:42:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
David Paschal memo (2.32 KB, text/plain)
2001-08-08 00:26 UTC, Pete Zaitcev
no flags Details
Draft fix (4.25 KB, patch)
2001-08-08 02:49 UTC, Pete Zaitcev
no flags Details | Diff
Fixed fix (4.31 KB, patch)
2001-08-15 00:27 UTC, Pete Zaitcev
no flags Details | Diff

Description Aleksey Nogin 2001-07-28 15:07:34 UTC
HP LaserJet 1200 doesn't work over USB out-of-the-box. However, if I edit
printer.c as suggested by
http://www.geocrawler.com/mail/msg.php3?msg_id=5622496&list=2571 ,
everything works fine.

This may be related to bug 26909, but I do not know enough about this stuff
to be sure.

Comment 1 Pete Zaitcev 2001-07-31 23:18:53 UTC
Please attach the contents of your /proc/bus/usb/devices.


Comment 2 Aleksey Nogin 2001-08-01 12:32:08 UTC
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=ff80
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=03f0 ProdID=0317 Rev= 1.00
S:  Manufacturer=HewLett Packard
S:  Product=HP LaserJet 1200
S:  SerialNumber=00CNBQ041594
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  2mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=07(print) Sub=01 Prot=03 Driver=usblp
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
I:  If#= 0 Alt= 1 #EPs= 2 Cls=07(print) Sub=01 Prot=02 Driver=usblp
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=  0ms
I:  If#= 0 Alt= 2 #EPs= 1 Cls=07(print) Sub=01 Prot=01 Driver=usblp
E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=  0ms

Comment 3 Pete Zaitcev 2001-08-03 23:43:27 UTC
Can you recompile kernels and apply patches for testing,
or do you need RPMs?


Comment 4 Aleksey Nogin 2001-08-04 13:35:24 UTC
Patches are OK (especially if I only need to recompile the modules and can avoid
rebooting).
RPM's are OK too.

P.S. I currently have printer attached to RH7.1 system + all updates. It's and
SMP system and I currently run 2.4.3-12smp from RH 7.1 updates).

Comment 5 Pete Zaitcev 2001-08-08 00:26:52 UTC
Created attachment 26753 [details]
David Paschal memo

Comment 6 Pete Zaitcev 2001-08-08 02:49:06 UTC
Created attachment 26773 [details]
Draft fix

Comment 7 Aleksey Nogin 2001-08-08 09:35:13 UTC
+
if (proto_bias == 1 && alt_711 != -1)
+
	return alt_713;
+
if (proto_bias == 2 && alt_712 != -1)
+
	return alt_713;
+
if (proto_bias == 3 && alt_713 != -1)
+
	return alt_713;

The above code seems suspicious. Are you sure you really meant to return alt_713
in all the cases?

Comment 8 Pete Zaitcev 2001-08-08 16:44:08 UTC
Looks like a copy-paste bug.


Comment 9 Pete Zaitcev 2001-08-15 00:27:52 UTC
Created attachment 27853 [details]
Fixed fix

Comment 10 Pete Zaitcev 2001-08-28 20:43:48 UTC
Marked as "Rawhide", but it made it into fairfax.



Note You need to log in before you can comment on or make changes to this bug.