Bug 502180 - update crash
update crash
Status: CLOSED DUPLICATE of bug 501129
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 07:37 EDT by Rahul Sundaram
Modified: 2013-03-13 01:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 05:36:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-05-22 07:37:25 EDT
Description of problem:

When I run a recent update with the latest PackageKit in rawhide, I got this:

--

Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 1830, in _runYumTransaction
    rpmDisplay=rpmDisplay)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3609, in processTransaction
    pkgs = self._downloadPackages(callback)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 3633, in _downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 1313, in downloadPkgs
    self.plugins.run('predownload', pkglist=pkglist)
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/presto.py", line 577, in predownload_hook
    (problems, more) = downloadPkgs(conduit, pinfo, download_pkgs)
  File "/usr/lib/yum-plugins/presto.py", line 419, in downloadPkgs
    cb.start(text="<delta rebuild>", size=rebuild_size)
  File "/usr/lib/python2.6/site-packages/urlgrabber/progress.py", line 129, in start
    self._do_start(now)
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2551, in _do_start
    self.updateProgress(name, 0.0, "", "")
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2593, in updateProgress
    pkg = self._getPackage(name)
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 2534, in _getPackage
    sections = name.rsplit('-', 2)
AttributeError: 'NoneType' object has no attribute 'rsplit'
Comment 1 Richard Hughes 2009-05-26 05:39:55 EDT
What version yum-presto?

Richard.
Comment 2 Rahul Sundaram 2009-05-26 05:48:26 EDT
#rpm -q yum-presto

yum-presto-0.5.0-1.fc11.noarch
Comment 3 Richard Hughes 2009-06-03 05:36:19 EDT

*** This bug has been marked as a duplicate of bug 501129 ***

Note You need to log in before you can comment on or make changes to this bug.