Bug 502186 - **package.jsp.menu.patches** in package overview page
**package.jsp.menu.patches** in package overview page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Dobies
Michael Mráka
:
Depends On:
Blocks: 456985 507280
  Show dependency treegraph
 
Reported: 2009-05-22 08:06 EDT by Jan Pazdziora
Modified: 2009-09-10 14:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:29:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the Overview page. (45.67 KB, image/png)
2009-05-22 08:06 EDT, Jan Pazdziora
no flags Details

  None (edit)
Description Jan Pazdziora 2009-05-22 08:06:58 EDT
Created attachment 345086 [details]
Screenshot of the Overview page.

Description of problem:

When viewing the package overview page of Solaris patch cluster, the menu is

    * Details
    * New Versions
    * **package.jsp.menu.patches**
    * Installed Systems
    * Installed Systems
    * Target Systems

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090520.0 on i386

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have Satellite 5.3.0.
2. Upload (rhnpush) Solaris patch cluster to some custom channel. You can use the one from bug 495778, once that bug is ON_QA.
3. Click on package -> Details -> Overview, /rhn/software/packages/Details.do?pid=xxx
  
Actual results:

    * Details
    * New Versions
    * **package.jsp.menu.patches**
    * Installed Systems
    * Installed Systems
    * Target Systems

and also see screenshot.

Expected results:

No text with stars.

Additional info:
Comment 1 Clifford Perry 2009-05-22 10:42:12 EDT
To my knowledge this is caused by missing English string translation. Should be easy to fix. 

Cliff.
Comment 2 Jay Dobies 2009-05-22 13:19:28 EDT
Master
commit	41a073371fb5b38e0c36c4997dae3cb8dae1575d
tree	9fd4ba71858409e90b8473ecb9870e50cb828ec6

Vader
commit	d323e693216abc10f44f9442f510debb85c0027c
tree	fe1e4a3727402514fb2dfc8547da410e7bedf48b

java/code/src/com/redhat/rhn/frontend/strings/jsp/StringResource_en_US.xml

Added missing resource key for solaris patches.
Comment 3 Michael Mráka 2009-06-08 10:01:15 EDT
VeRified. Satellite-5.3.0-RHEL4-re20090529.0-x86_64

Details
New Versions
Patches
Installed Systems
Installed Systems
Target Systems
Comment 4 Miroslav Suchý 2009-08-19 10:03:00 EDT
verified in stage on xen5:

    * Details
    * New Versions
    * Patches
    * Installed Systems
    * Installed Systems
    * Target Systems
Comment 5 Brandon Perkins 2009-09-10 14:29:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.