Bug 502205 - cups-lpd exact cups-libs version dependency
cups-lpd exact cups-libs version dependency
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Tim Waugh
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 10:57 EDT by Jan Lieskovsky
Modified: 2010-03-30 04:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:15:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Lieskovsky 2009-05-22 10:57:20 EDT
Description of problem:

From rpmdiff result
https://errata.devel.redhat.com/rpmdiff/show/38074.?result_id=383730 :

Subpackage cups-lpd on i386 ppc s390 consumes library(s) libcups.so.2 from subpackage cups-libs but does not have explicit package version requirement cups-libs = 1.3.7-8.el5_3.5<br/>Please add Requires: cups-libs = %{version}-%{release} to cups-lpd in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

Version-Release number of selected component (if applicable):
cups-1.3.7-8.el5_3.5
Comment 1 Tim Waugh 2009-06-02 03:42:22 EDT
There isn't actually any problem here because:

  cups-lpd requires cups = %{version}-%{release}
  cups requires cups-libs = %{version}-%{release}

so as a result cups-lpd already requires cups-libs = %{version}-%{release} transitively through the main package.

So the question is whether we want to make this explicit in order to pacify rpmdiff.
Comment 2 Phil Knirsch 2009-10-12 13:00:58 EDT
Transitive requirement resolving should be ok, we rely on it in many other forms throughout the distribution.

The fix would be easy, but i'm unsure if it is really required.

Thanks & regards, Phil
Comment 3 Tim Waugh 2009-10-27 13:01:17 EDT
It's not required.
Comment 5 Tim Waugh 2009-11-10 11:48:49 EST
Fix committed.
Comment 9 errata-xmlrpc 2010-03-30 04:15:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0210.html

Note You need to log in before you can comment on or make changes to this bug.