Bug 502263 - Audio Kontrol 1 by Native Instruments does not show up as input/output device in sound preferences
Audio Kontrol 1 by Native Instruments does not show up as input/output device...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 16:37 EDT by Nils Björklund
Modified: 2009-06-29 08:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 08:25:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Björklund 2009-05-22 16:37:04 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4

When I connect my USB2 soundcard of the model Audio Kontrol 1 by Native Instruments, it does not show up as a device in either input or output tab of the Sound Preferences in the default gnome desktop.

The device is supported by the snd-usb-caiaq module and seems to work correctly otherwise, except that the device name given by alsa is bad.

Reproducible: Always

Steps to Reproduce:
1. Connect Audio Kontrol 1

Actual Results:  
The device does not show up in the sound preferences dialog. The device works in alsa but has a bad description: 
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: default [], device 0:  []
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

card 1 is the Audio Kontrol 1.

Expected Results:  
The device shows up in the sound preferences dialog. The device should be given a more descriptive name by alsa.

Excerpt from messages:

-----snip-----

May 22 21:40:05 localhost kernel: usb 1-2: new high speed USB device using ehci_hcd and address 3
May 22 21:40:05 localhost kernel: usb 1-2: string descriptor 0 read error: -61
May 22 21:40:05 localhost kernel: usb 1-2: string descriptor 0 read error: -61
May 22 21:40:05 localhost kernel: usb 1-2: string descriptor 0 read error: -61
May 22 21:40:05 localhost kernel: usb 1-2: New USB device found, idVendor=17cc, idProduct=0815
May 22 21:40:05 localhost kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=5
May 22 21:40:05 localhost kernel: usb 1-2: configuration #1 chosen from 1 choice
May 22 21:40:05 localhost kernel: usb 1-2: string descriptor 0 read error: -61
May 22 21:40:06 localhost kernel: usb 1-2: string descriptor 0 read error: -61
May 22 21:40:06 localhost kernel: usb 1-2: string descriptor 0 read error: -61
May 22 21:40:06 localhost kernel: usb 1-2: string descriptor 0 read error: -61
May 22 21:40:06 localhost kernel: usb 1-2: string descriptor 0 read error: -61
May 22 21:40:06 localhost kernel: input:  as /devices/pci0000:00/0000:00:1d.7/usb1/1-2/input/input11
May 22 21:40:06 localhost kernel: usbcore: registered new interface driver snd-usb-caiaq
May 22 21:40:06 localhost pulseaudio[1968]: module-alsa-card.c: Failed to find a working profile.
May 22 21:40:06 localhost pulseaudio[1968]: module.c: Failed to load  module "module-alsa-card" (argument: "device_id=1 name=usb_device_17cc_815_noserial_sound_card_0 card_name=alsa_card.usb_device_17cc_815_noserial_sound_card_0 tsched=1"): initialization failed.

-----snip-----

$ uname -a
Linux localhost.localdomain 2.6.29.3-155.fc11.i586 #1 SMP Wed May 20 17:16:59 EDT 2009 i686 i686 i386 GNU/Linux

$ lsusb
Bus 001 Device 003: ID 17cc:0815 Native Instruments Audio Kontrol 1

$ aconnect -io
client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
client 20: 'External MIDI' [type=kernel]
    0 'MIDI 1-0-0      '
    1 'MIDI 1-0-1      '
Comment 1 Lennart Poettering 2009-05-23 17:12:09 EDT
The driver needs to support at least the "front:xxx" device string to be correctly identified by PA.

Does it support that?

i.e. does "aplay -f CD -D front:1 < /dev/urandom" work?
Comment 2 Nils Björklund 2009-05-24 08:04:57 EDT
(In reply to comment #1)
> i.e. does "aplay -f CD -D front:1 < /dev/urandom" work? 

$ aplay -f CD -D front:1 < /dev/urandom
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.snd-usb-caiaq.pcm.front.0:CARD=1'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM front:1
aplay: main:608: audio open error: No such file or directory

No, it does not work. It seems something must be added/fixed in alsa then?

Also the device only supports the S24_3BE format with 2 channels and sample rates 44100, 48000, 88200, 96000 and 192000. Will this a problem?

$ aplay -f S24_3BE -c 2 -r 44100 -D hw:1 < /dev/urandom
Playing raw data 'stdin' : Signed 24 bit Big Endian in 3bytes, Rate 44100 Hz, Stereo
Comment 3 Lennart Poettering 2009-05-24 16:31:50 EDT
PA git works with S24_32BE perfectly after I wroked with the Caiaq guys on that.

All that's missing to make PA detect those devices by default is that alsa-libs includes definitions for front:xxx and friends.

I'll ping Caiaq's Daniel Mack about that.
Comment 4 Lennart Poettering 2009-05-24 16:51:26 EDT
Nils, I assume that "aplay -f CD -D plug:front:1 < /dev/urandom" doesn't work either, right?
Comment 5 Lennart Poettering 2009-05-24 16:53:08 EDT
BTW, I assume that this is F11, right?
Comment 6 Nils Björklund 2009-05-24 17:22:49 EDT
> PA git works with S24_32BE perfectly after I wroked with the Caiaq guys on
> that.
That is great to know. I bought this sound card because it was supported in Linux by the manufacturer. (I haven't really figured out the relationship between Caiaq and Native Instruments yet. Caiaq designs the hardware for Native Instruments?)

> Nils, I assume that "aplay -f CD -D plug:front:1 < /dev/urandom" doesn't work
> either, right?  
$ aplay -f CD -D plug:front:1 < /dev/urandom
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.snd-usb-caiaq.pcm.front.0:CARD=1'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM front:1
aplay: main:608: audio open error: No such file or directory

Same error.

> BTW, I assume that this is F11, right?
Yes, I installed the F11 prerelease.
Comment 7 Lennart Poettering 2009-05-25 22:21:12 EDT
(In reply to comment #6)
> > PA git works with S24_32BE perfectly after I wroked with the Caiaq guys on
> > that.
> That is great to know. I bought this sound card because it was supported in
> Linux by the manufacturer. (I haven't really figured out the relationship
> between Caiaq and Native Instruments yet. Caiaq designs the hardware for Native
> Instruments?)

Yes, their relation is similar to that AFAIU.

Hmm, the Caiaq guys say this works on their machines. Weird.
Comment 8 Bug Zapper 2009-06-09 12:23:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Lennart Poettering 2009-06-29 08:25:41 EDT
This is fixed in the -14 packages in F11 I believe.

Note You need to log in before you can comment on or make changes to this bug.