Bug 502271 - Update to 2.5.1, separate darkplaces engine, add Quake 1 support
Update to 2.5.1, separate darkplaces engine, add Quake 1 support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nexuiz (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 17:34 EDT by Ville Skyttä
Modified: 2009-05-27 12:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 12:19:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nexuiz patch (11.45 KB, patch)
2009-05-22 17:34 EDT, Ville Skyttä
no flags Details | Diff
nexuiz-data patch (1.38 KB, patch)
2009-05-22 17:35 EDT, Ville Skyttä
no flags Details | Diff
Disable parallel build (1.08 KB, patch)
2009-05-27 11:36 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2009-05-22 17:34:37 EDT
Created attachment 345166 [details]
nexuiz patch

I wanted to play Quake 1 and found that the engine in Nexuiz supports it as is.  The attached patch separates the darkplaces engine into separate packages and makes nexuiz and quake thin wrapper packages over the darkplaces ones.  The quake one comes with autodownloader support.

While at it, I updated nexuiz to 2.5.1 and came up with some other trivial fixes to it, patches attached.
Comment 1 Ville Skyttä 2009-05-22 17:35:21 EDT
Created attachment 345168 [details]
nexuiz-data patch
Comment 2 Gwyn Ciesla 2009-05-26 15:08:14 EDT
Looks good, committed nexuiz, uploading nexuiz-data.  Thanks!
Comment 3 Ville Skyttä 2009-05-26 16:15:13 EDT
Thanks.  darkplaces-quake.autodlrc, darkplaces-quake.desktop, darkplaces-quake.sh, and nexuiz.desktop seem to be missing from nexuiz/devel in CVS at the moment though...
Comment 4 Gwyn Ciesla 2009-05-26 16:23:14 EDT
Thanks, good catch.  Long day.

Still uploading -data.
Comment 5 Gwyn Ciesla 2009-05-27 09:43:47 EDT
-data built for f-12.  nexuiz not so much:

http://koji.fedoraproject.org/koji/getfile?taskID=1379422&name=build.log
Comment 6 Ville Skyttä 2009-05-27 11:36:41 EDT
Created attachment 345629 [details]
Disable parallel build

Looks like a parallel build issue that didn't bite on my local (uniprocessor, make -j3) box.  If so, this patch should take care of it, and did in scratch builds:

Parallel: http://koji.fedoraproject.org/koji/taskinfo?taskID=1379658
No parallel: http://koji.fedoraproject.org/koji/taskinfo?taskID=1379660
Comment 7 Gwyn Ciesla 2009-05-27 12:19:49 EDT
There we are.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.