Bug 502296 - libcaca fails to build on F-12 and breaks xine-ui
libcaca fails to build on F-12 and breaks xine-ui
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libcaca (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-23 05:35 EDT by Michael Schwendt
Modified: 2009-06-11 06:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-11 06:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-05-23 05:35:06 EDT
Failed x86_64 scratch build for devel/F-12:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1372446

It's failing due to missing libGLU, which the freeglut upgrade is no longer linked to:

> ../caca/.libs/libcaca.so: undefined reference to `gluOrtho2D'


Older xine-ui build failure due to libcaca:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1361378
Comment 1 Bug Zapper 2009-06-09 12:25:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matthias Saou 2009-06-11 06:58:47 EDT
I've just rebuilt 0.99-0.8.beta16.fc12, where I've included the changes which should be sufficient for the library to now link properly against libGLU.

Note You need to log in before you can comment on or make changes to this bug.