Bug 502317 - Fedora 9, 10 and 11 lock up hard during boot on Jetway NF76-N1GL-LF (VIA Nano)
Fedora 9, 10 and 11 lock up hard during boot on Jetway NF76-N1GL-LF (VIA Nano)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-23 15:49 EDT by Henning Norén
Modified: 2013-01-13 07:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-14 14:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from booting with Fedora 8 (23.25 KB, text/plain)
2009-05-23 15:49 EDT, Henning Norén
no flags Details
lspci -vvv from Fedora 8 (17.66 KB, text/plain)
2009-05-23 15:51 EDT, Henning Norén
no flags Details
Fedora 11 dmesg (idle=poll) (34.58 KB, text/plain)
2009-05-25 19:07 EDT, Henning Norén
no flags Details

  None (edit)
Description Henning Norén 2009-05-23 15:49:57 EDT
Created attachment 345205 [details]
dmesg from booting with Fedora 8

Description of problem:
Fedora 9 and later (including Fedora rawhide snapshot from 2009-05-22) will not boot on Jetway NF76-N1GL-LF - VIA Nano U2300 board (VX800 chipset). The system locks up hard and need a hard reset as keyboard will not respond anymore (num lock is dead and ctrl-alt-delet does not work).
Fedora 8 Live USB boots perfectly but no later version tested will boot.

Not error message, oops, or warning is shown that hint about the issue.

Version-Release number of tested components (if applicable):
Fedora 8 Live USB i686 (kernel 2.6.23) <- This one works fine!
Fedora 9 Live USB i686 (kernel 2.6.25)
Fedora 10 Live USB i686 (kernel 2.6.27)
Fedora 11 Preview Release i386 (kernel 2.6.29)
Fedora 11 Preview Release x86-64 (kernel 2.6.29)
Fedora 11 Rawhide snapshot 2009-05-22 i386 (kernel 2.6.29)
Fedora 11 Rawhide Snapshot 2009-05-22 x86-64 (kernel 2.6.29)



How reproducible:
Always

Steps to Reproduce:
1. Boot from any release of Fedora, later than Fedora 8
  
Actual results:
(last seen on screen on Fedora 11 Preview release, manually typed so spelling errors are mine):

ACPI Warning (dsobject-0502): Package List length (8) larger than NumElements count (2), truncated
 [20081204]
ACPI: Interpreter enabled
ACPI: (supports S0 S1 S4 S5)
ACPI: Using IOAPIC for interrupt routing
ACPI: No dock devices found
ACPI: PCI Root Bridge [PCI0] (0000:00)
pci 0000:00:02.0: PME# supported from D0 D3hot D3cold
pci 0000:00:02.0: PME# disabled
pci 0000:00:03.0: PME# supported from D0 D3hot D3cold
pci 0000:00:03.0: PME# disabled
pci 0000:00:03.1: PME# supported from D0 D3hot D3cold
pci 0000:00:03.1: PME# disabled
pci 0000:00:10.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.0: PME# disabled
pci 0000:00:10.1: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.1: PME# disabled
pci 0000:00:10.2: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.2: PME# disabled
pci 0000:00:10.4: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.4: PME# disabled
pci 0000:02:00.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:02:00.0: PME# disabled

When booting with ACPI off:

PCI: Using configuration type 1 for base access
bio: create slab <bio-0> at 0
ACPI: Interpreter disabled
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PCI: Probing PCI hardware
pci 0000:00:02.0: PME# supported from D0 D3hot D3cold
pci 0000:00:02.0: PME# disabled
pci 0000:00:03.0: PME# supported from D0 D3hot D3cold
pci 0000:00:03.0: PME# disabled
pci 0000:00:03.1: PME# supported from D0 D3hot D3cold
pci 0000:00:03.1: PME# disabled
pci 0000:00:10.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.0: PME# disabled
pci 0000:00:10.1: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.1: PME# disabled
pci 0000:00:10.2: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.2: PME# disabled
pci 0000:00:10.4: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:10.4: PME# disabled
pci 0000:02:00.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:02:00.0: PME# disabled


Expected results:
System boots up (or at least spits out a error)

Additional info:

The issue seems very similar to what been reported on Kernel mailinglist:
http://marc.info/?l=linux-kernel&m=124074183920249&w=2

Fedora 8 works just fine after booting and seems stable.
Comment 1 Henning Norén 2009-05-23 15:51:42 EDT
Created attachment 345206 [details]
lspci -vvv from Fedora 8

Cpuinfo from Fedora 8:

processor	: 0
vendor_id	: CentaurHauls
cpu family	: 6
model		: 15
model name	: VIA Nano processor U2300@1000MHz
stepping	: 2
cpu MHz		: 997.582
cache size	: 1024 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush acpi mmx fxsr sse sse2 ss tm syscall nx fxsr_opt rdtscp lm up pni monitor vmx est tm2 ssse3 cx16 xtpr rng rng_en ace ace_en ace2 phe phe_en lahf_lm
bogomips	: 1996.26
clflush size	: 64


lspci from Fedora 8:

00:00.0 Host bridge: VIA Technologies, Inc. Unknown device 0353 (rev 12)
00:00.1 Host bridge: VIA Technologies, Inc. Unknown device 1353
00:00.2 Host bridge: VIA Technologies, Inc. Unknown device 2353
00:00.3 Host bridge: VIA Technologies, Inc. Unknown device 3353
00:00.4 Host bridge: VIA Technologies, Inc. Unknown device 4353
00:00.5 PIC: VIA Technologies, Inc. Unknown device 5353
00:00.6 Host bridge: VIA Technologies, Inc. Unknown device 6353
00:00.7 Host bridge: VIA Technologies, Inc. Unknown device 7353
00:01.0 VGA compatible controller: VIA Technologies, Inc. Unknown device 1122 (rev 11)
00:02.0 PCI bridge: VIA Technologies, Inc. Unknown device c353
00:03.0 PCI bridge: VIA Technologies, Inc. Unknown device e353
00:03.1 PCI bridge: VIA Technologies, Inc. Unknown device f353
00:0f.0 IDE interface: VIA Technologies, Inc. CX700M2 IDE
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
00:11.0 ISA bridge: VIA Technologies, Inc. Unknown device 8353
00:11.7 Host bridge: VIA Technologies, Inc. Unknown device a353
00:13.0 PCI bridge: VIA Technologies, Inc. Unknown device b353
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
04:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)
04:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)
04:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)
Comment 2 Chuck Ebbert 2009-05-25 15:34:57 EDT
Did you try changing the idle routine? Try the idle=poll and/or idle=halt boot options.
Comment 3 Henning Norén 2009-05-25 19:07:02 EDT
Created attachment 345364 [details]
Fedora 11 dmesg (idle=poll)

I had no idea about those options.

If I use any one of them, the system boots correctly on Fedora 11 Preview (I assume F10 and F9 too, not tested though).

Do let me know if you need any help resolving/finding the issue why the boot is stuck without the options.
I suppose that the priority can be lowered as the big road-block is now gone.
Comment 4 Chuck Ebbert 2009-05-27 14:11:03 EDT
idle=halt will run cooler and use less power. You could also try processor.max_cstate=1, processor.max_cstate=2 etc. and find the highest number that works.
Comment 5 Chuck Ebbert 2009-05-27 17:52:11 EDT
Looks like the proper option to use is "idle=nomwait", as mwait is broken on these processors. A BIOS update may become available in the future to make the option unnecessary.
Comment 6 Henning Norén 2009-05-30 19:56:18 EDT
Did a test of all idle options with 2.6.29.3-155.fc11.i686.PAE:

These showed the same problem as I've seen before:
no option - Stuck while booting
idle=nomwait - Stuck while booting
idle=mwait

These worked:
idle=poll
idle=halt

I completly reset the BIOS (latest version, A02) to make sure that no option I had set was making the results unreliable.

Let me know if there is anything else I should test.
Comment 7 Chuck Ebbert 2009-06-01 11:25:32 EDT
Please post the contents of /proc/cpuinfo from that machine.
Comment 8 Henning Norén 2009-06-01 17:23:59 EDT
processor       : 0
vendor_id       : CentaurHauls
cpu family      : 6
model           : 15
model name      : VIA Nano processor U2300@1000MHz
stepping        : 2
cpu MHz         : 531.976
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush acpi mmx fxsr sse sse2 ss tm syscall nx fxsr_opt rdtscp lm up pni monitor vmx est tm2 ssse3 cx16 xtpr rng rng_en ace ace_en ace2 phe phe_en lahf_lm
bogomips	: 1063.95
clflush size	: 64
power management:
Comment 9 Chuck Ebbert 2009-06-09 00:10:18 EDT
Same processor in a Samsung NC20 works without any extra options. Looks like a BIOS update is needed to fix this properly.
Comment 10 Bug Zapper 2009-06-09 12:26:57 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Henning Norén 2009-06-09 17:47:26 EDT
I just noticed the comment about processor.max_cstate and I tried that too but it did not even boot with processor.max_cstate=1

I will now contact Jetway Support and the seller of the motherboard to see if they can look into this issue and provide a BIOS update or possibly some other information about it.

Thank you for your help looking into this!

As soon as I have some news, I will update this ticket accordingly.
Comment 12 Henning Norén 2009-06-14 14:36:56 EDT
Fixed after grabbing BIOS vA03 from Jetway download page which is now available and contain a microcode update.

Note You need to log in before you can comment on or make changes to this bug.