Bug 502320 - Clear private data does not fully clear browsing history
Clear private data does not fully clear browsing history
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-23 17:18 EDT by Jonathan Underwood
Modified: 2009-06-05 13:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-05 08:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 477353 None None None Never
Mozilla Foundation 502320 None None None Never

  None (edit)
Description Jonathan Underwood 2009-05-23 17:18:10 EDT
Description of problem:
Tools->Clear private data doesn't actually delete the browsing history completely when the Browsing Data checkbox is ticked

Version-Release number of selected component (if applicable):
firefox-3.0.10-1.fc10.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.Clear private data
2.Restart firefox just in case it's needed to clear state
3.Click on location bar, and up pops a list of websites visited.
  
Actual results:
Browsing history not cleared

Expected results:
Browsing history cleared

Additional info:
Comment 1 Matěj Cepl 2009-06-02 09:17:34 EDT
We found this bug to be already filed in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=477353) and believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 2 Jonathan Underwood 2009-06-02 09:28:53 EDT
Why are you closing Fedora bugs with generic *Red Hat* templates?

Also, the upstream bug linked to is a) reported against the Vista builds; b) conflates two different issues; and c) has had no attention from upstream.

This is the last bug I can be bothered filing against firefox/thunderbird on the Fedora bug tracker - they're always ignored or closed as upstream of some other unrelated bug.

Yeah, unimpressed.
Comment 3 Matěj Cepl 2009-06-02 10:03:14 EDT
(In reply to comment #2)
> Why are you closing Fedora bugs with generic *Red Hat* templates?

Because, I am Red Hat and *I* am subscribed to the upstream bug.

> Also, the upstream bug linked to is a) reported against the Vista builds; b)
> conflates two different issues; and c) has had no attention from upstream.

I don't think platform matters in this case (yes, that's just my guess). My experience is that usually upstream reacts reasonably on time to bugs where we make a comment or other noise.

> This is the last bug I can be bothered filing against firefox/thunderbird on
> the Fedora bug tracker - they're always ignored or closed as upstream of some
> other unrelated bug.

You're welcome.
Comment 4 Matěj Cepl 2009-06-02 10:19:20 EDT
(In reply to comment #2)
> This is the last bug I can be bothered filing against firefox/thunderbird on
> the Fedora bug tracker - they're always ignored or closed as upstream of some
> other unrelated bug.

Alternative to moving bugs upstream (where we can share the work with other engineers interested in Firefox) is that they will stay rottening in our Bugzilla forever ... we have just so much capacity for fixing Gecko & co. bugs. What would you prefer?
Comment 5 Jonathan Underwood 2009-06-02 10:27:28 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > Why are you closing Fedora bugs with generic *Red Hat* templates?
> 
> Because, I am Red Hat and *I* am subscribed to the upstream bug.
> 

The problem is, it's confusing. It gives the impression that Red Hat has high handedly decided that the Fedora project/community isn't going to fix the bug. Or, alternatively, it could be  interpreted as Red Hat taking responsibility for
Fedora bugs in an official capacity, which would also be a bit surprising. In
short, it's plain confusing and unhelpful to be muddying the distinction
between Red Hat and Fedora by closing bugs with templates designed (presumably)
for RHEL bugs.

I'd suggest s/Red Hat/We in your template, because what you actually mean is "The firefox package maintainers for the Fedora project".
Comment 6 Jonathan Underwood 2009-06-02 10:29:52 EDT
(In reply to comment #4)
> (In reply to comment #2)
> > This is the last bug I can be bothered filing against firefox/thunderbird on
> > the Fedora bug tracker - they're always ignored or closed as upstream of some
> > other unrelated bug.
> 
> Alternative to moving bugs upstream (where we can share the work with other
> engineers interested in Firefox) is that they will stay rottening in our
> Bugzilla forever ... we have just so much capacity for fixing Gecko & co. bugs.
> What would you prefer?  

Sure - I totally get that, I totally agree with moving the bugs upstream, and perhaps I should've reported there in the first place. I searched the upstream bugzilla before submitting the bug here to see if it was likely to be specific to the fedora package or not. Not seeing anything in the upstream bugzilla that was clearly the issue I was seeing, I reported it against the Fedora package first. What is a bit annoying is closing this bug as upstream against an upstream bug which, to me at least, is not clearly the same bug.
Comment 7 Christopher Aillon 2009-06-02 13:07:46 EDT
Let me step in here for a second, as ultimately, the package is my responsibility as the maintainer.

First, let me thank you for the report.  Honestly, we do read them all, as they provide useful feedback to us.  I want to apologize for the wording that was used.  I agree it is a little confusing, and I think your suggested change is reasonable, and will make sure we incorporate that in the future.

Also, I'd like to apologize for the bug being closed against the wrong bug.  We're only human and mistakes do happen at times.  Triaging bugs is largely a thankless job, and when pouring over bugs, mistakes can sometimes happen even though we try hard to get it right.  I can see why the upstream bug was chosen, even though it may not have been the ideal choice for the reasons you gave.

So, I'm going to re-open this bug for now.  I think we should still be moving this upstream, but to a more appropriate bug (if we can't find one, we can make sure one gets filed).

Again, your feedback is valuable and is heard by us even though we don't always get things right (but then again, I guess that's why bugs are filed to begin with).  I appreciate your bugs as they are generally well-filed, and sincerely hope that you continue to file bugs as you find them, either here or upstream as you deem appropriate.  In the future, if you feel like issues filed against Fedora aren't getting the attention they deserve, feel free to find me on IRC or email.
Comment 8 Matěj Cepl 2009-06-04 10:55:30 EDT
(In reply to comment #7)
> I want to apologize for the wording that was
> used.  I agree it is a little confusing, and I think your suggested change is
> reasonable, and will make sure we incorporate that in the future.

Fixed.
Comment 9 Jonathan Underwood 2009-06-04 12:14:08 EDT
Thanks.
Comment 10 Matěj Cepl 2009-06-05 08:57:32 EDT
OK, searched around and I haven't find anything better, so filed a new bug.
Comment 11 Matěj Cepl 2009-06-05 11:25:00 EDT
Reporter, can I ask you for commenting on the upstream bug (https://bugzilla.mozilla.org/show_bug.cgi?id=496561), please?
Comment 12 Jonathan Underwood 2009-06-05 11:50:30 EDT
(In reply to comment #11)
> Reporter, can I ask you for commenting on the upstream bug
> (https://bugzilla.mozilla.org/show_bug.cgi?id=496561), please?  

OK, have done - I think the confusion is perhaps because you reported it against version 3.5beta (F11), rather than 3.0 (F10). Thanks for reporting it upstream - I had planned to get to that when I had a spare moment. But they're rare :).
Comment 13 Matěj Cepl 2009-06-05 13:41:25 EDT
(In reply to comment #12)
> OK, have done - I think the confusion is perhaps because you reported it
> against version 3.5beta (F11), rather than 3.0 (F10). Thanks for reporting it
> upstream - I had planned to get to that when I had a spare moment. But they're
> rare :).  

As noted in the upstream bug ... I have reproduced it with 3.5beta4 and yes menus are slightly different but functionality is the same.

Note You need to log in before you can comment on or make changes to this bug.