Bug 502325 - X uses wrong resolution when started with monitor off (visa)
X uses wrong resolution when started with monitor off (visa)
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-23 19:59 EDT by Arthur Pemberton
Modified: 2009-11-07 18:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-07 18:25:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/dmesg (29.52 KB, text/plain)
2009-05-23 20:00 EDT, Arthur Pemberton
no flags Details
lspci | grep VGA (79 bytes, text/plain)
2009-05-23 20:00 EDT, Arthur Pemberton
no flags Details
/etc/X11/xorg.conf (320 bytes, text/plain)
2009-05-23 20:01 EDT, Arthur Pemberton
no flags Details
/var/log/Xorg.0.log (39.64 KB, text/plain)
2009-05-23 20:01 EDT, Arthur Pemberton
no flags Details

  None (edit)
Description Arthur Pemberton 2009-05-23 19:59:47 EDT
Description of problem:
X doesn't remember the appropriate resolution settings, and does not know what
to do when started without a monitor, so default to an "ugly" resolution.

Version-Release number of selected component (if applicable):
All version since F7, including those available in Centos 5.x

How reproducible:
Every time

Steps to Reproduce:
1. Turn on computer
2. Boot in to Fedora or Centos
3. Ensure monitor is off before X starts

Actual results:
X chooses some horrible resolution.

Expected results:
X uses last working resolution

Additional info:
1. Neither of the major desktop OSes seem to have this problem
2. There is no obvious solution (obvious meaning can't solve without
understanding  the problem)
3. This is happening on every install of Fedora or Centos where a monitor may
be off, including KVM setups
4. I can't imaging how this looks/seems to new users, I can't imagine that it
is good
5. Even for people like myself who know to Ctrl+Alt+Backspace it is very
annoying to always have to remember to put on my monitor, or have to restart X
6. I have set the severity to medium, but I've been enduring this since F7
hoping that it will be fixed eventually, but it hasn't 


Spawned from https://bugzilla.redhat.com/show_bug.cgi?id=490082
by request of https://bugzilla.redhat.com/show_bug.cgi?id=490082#c12
Comment 1 Arthur Pemberton 2009-05-23 20:00:29 EDT
Created attachment 345214 [details]
/var/log/dmesg
Comment 2 Arthur Pemberton 2009-05-23 20:00:46 EDT
Created attachment 345215 [details]
lspci | grep VGA
Comment 3 Arthur Pemberton 2009-05-23 20:01:30 EDT
Created attachment 345216 [details]
/etc/X11/xorg.conf
Comment 4 Arthur Pemberton 2009-05-23 20:01:50 EDT
Created attachment 345217 [details]
/var/log/Xorg.0.log
Comment 5 Arthur Pemberton 2009-11-07 18:25:42 EST
No longer have hardware for this bug. And no on seemed interested originally.

Note You need to log in before you can comment on or make changes to this bug.