Bug 502353 - rpm_check_debug prints 'rpmlib(FileDigests) is needed by ...'
rpm_check_debug prints 'rpmlib(FileDigests) is needed by ...'
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-24 08:36 EDT by Richard W.M. Jones
Modified: 2010-05-12 07:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 07:19:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-05-24 08:36:05 EDT
This happens using yum when trying to compile
libguestfs on Debian:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by upstart-0.3.9-24.fc11.x86_64
rpmlib(FileDigests) is needed by ntfs-3g-2009.4.4-1.fc11.i586
[...]

libguestfs 1.0.31
Debian 5.0.1 x86_64
Comment 1 Richard W.M. Jones 2009-05-24 08:38:15 EDT
Upstream yum bug apparently is:
http://yum.baseurl.org/ticket/79
Comment 2 Richard W.M. Jones 2009-05-24 09:09:03 EDT
Temporary workaround is to install the F-10 appliance, ie:

./configure --with-repo=fedora-10 --with-updates=updates-released-f10
Comment 3 Mark McLoughlin 2009-05-25 11:07:25 EDT
Moving upstream, since it's about building on Debian ... even though it's due to a yum/Fedora bug? Funky
Comment 4 Richard W.M. Jones 2010-05-12 07:19:57 EDT
We're building libguestfs fine on Debian now, so closing.

Note You need to log in before you can comment on or make changes to this bug.