Bug 502365 - RAMDISK: incomplete write (-28 != 32768) 16777216
RAMDISK: incomplete write (-28 != 32768) 16777216
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-24 09:53 EDT by Richard W.M. Jones
Modified: 2009-05-24 10:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-24 10:42:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-05-24 09:53:27 EDT
Appliance fails to boot.  When you boot with LIBGUESTFS_DEBUG=1
you see messages such as:

RAMDISK: Compressed image found at block 0
RAMDISK: incomplete write (-28 != 32768) 16777216

RAMDISK: Compressed image found at block 0
RAMDISK: incomplete write (-28 != 32768) 40960000

(The precise numbers may be slightly different).
Comment 1 Richard W.M. Jones 2009-05-24 09:56:46 EDT
This error only happens when we try to run libguestfs
on Debian (still using Fedora inside the appliance of
course).

We found by googling and experimentation that we can
get rid of the 'RAMDISK: incomplete write' error by adding
ramdisk=NNN option, eg:

LIBGUESTFS_APPEND="ramdisk_size=128000"

However this doesn't in itself resolve the problem with
booting.
Comment 2 Richard W.M. Jones 2009-05-24 09:57:48 EDT
(In reply to comment #1)
> ramdisk=NNN option, eg:

That should be 'ramdisk_size=NNN' of course.
Comment 3 Richard W.M. Jones 2009-05-24 10:42:46 EDT
False alarms all round - the ramdisk_size parameter is NOT needed.

The problem was that Debian's cpio command defaults to using
the obsolete 'bin' cpio format, not 'newc' (which is what Fedora
defaults to).  Therefore Debian's cpio was making an initramfs
image that the kernel simply couldn't understand.

Fixes to this are:
http://git.et.redhat.com/?p=febootstrap.git;a=commit;h=346a893d8035212e8d2acbe3a14521df504116e2
http://git.et.redhat.com/?p=febootstrap.git;a=commit;h=0eacd743cb1ff655a09f7b941320a0235d482df0

Note You need to log in before you can comment on or make changes to this bug.