Bug 502394 - complaints from yum update
complaints from yum update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-24 14:15 EDT by Donald Cohen
Modified: 2016-11-24 07:42 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 14:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
transcript of yum update (17.41 KB, application/octet-stream)
2009-05-24 14:21 EDT, Donald Cohen
no flags Details
same transcript (17.41 KB, text/plain)
2009-05-24 14:24 EDT, Donald Cohen
no flags Details
partial transcript of second yum update (20.74 KB, text/plain)
2009-05-31 17:12 EDT, Donald Cohen
no flags Details
attempt to startx (3.05 KB, text/plain)
2009-05-31 17:12 EDT, Donald Cohen
no flags Details

  None (edit)
Description Donald Cohen 2009-05-24 14:15:31 EDT
Description of problem:
I can't tell whether this is a problem with yum or with the particular components being updated, or even with my previous installation state, but I just did a yum update and saw some messages that I find worrying.
Please let me know whether all is well or there is a problem, and if so what to do about it.

The messages are of two types:
- some .so is not an ELF file
- some .so is not a symbolic link
The complaints come from updates to cairomm, totem-gstreamer, totem-xine

The transcript is attached.


Additional info:
Another problem that I find cause for concern, which in fact is what caused me to do the yum update in the first place, is that I got the following error from cvs:
$ cvs up 
cvs: error while loading shared libraries: libdes425.so.3: cannot dynamically load executable

This had worked before.  In fact, the error came from a daily cron job.
 $ locate libdes425
 /usr/lib64/libdes425.so
 /usr/lib64/libdes425.so.3
 /usr/lib64/libdes425.so.3.0
 $ ls -l /usr/lib64/libdes425.so*
 lrwxrwxrwx 1 root root    16 2009-04-09 10:15 /usr/lib64/libdes425.so ->  libdes425.so.3.0
 -rwxr-xr-x 1 root root 14752 2008-08-05 14:14 /usr/lib64/libdes425.so.3
 -rwxr-xr-x 1 root root 15144 2009-04-07 11:26 /usr/lib64/libdes425.so.3.0
 [2009-05-24 10:36:28 root@number11 ~/clisp]
 $ cp /usr/lib64/libdes425.so.3 /usr/lib64/libdes425.so.3-old
 $ cp /usr/lib64/libdes425.so.3.0  /usr/lib64/libdes425.so.3
 cp: overwrite `/usr/lib64/libdes425.so.3'? y
 $ cvs up -d
... now works

This seems related to the problem above, and equally inexplicable to me, so the same questions apply.
Comment 1 Donald Cohen 2009-05-24 14:21:43 EDT
Created attachment 345260 [details]
transcript of yum update
Comment 2 Donald Cohen 2009-05-24 14:24:37 EDT
Created attachment 345262 [details]
same transcript

The other one seems to be auto detected as a "bin" file.
This one I explicitly describe as plain text.
Comment 3 James Antill 2009-05-26 00:21:36 EDT
 This is ldconfig complaining ... not yum.
 As to why, I'm not sure ... do you have glibc.x86_64 installed?
Comment 4 Donald Cohen 2009-05-26 00:29:22 EDT
(In reply to comment #3)
>  This is ldconfig complaining ... not yum.
>  As to why, I'm not sure ... do you have glibc.x86_64 installed?  

Yes, yum list installed says
glibc.x86_64         2.9-3        installed
Comment 5 Donald Cohen 2009-05-31 17:10:22 EDT
Now that I have had to reboot and cannot start X, and that trying to do so generates errors like this:
 ** (gnome-settings-daemon:3468): WARNING **: /usr/lib64/libgnomekbd.so.3: invalid   
 ELF header
and
 ** (gnome-settings-daemon:3468): WARNING **: Cannot load plugin 'Keyboard' since 
 file '/usr/lib64/gnome-settings-daemon-2.0/libkeyboard.so' cannot be read.
I begin to think that the complaints above are real.
I have done another yum update recently, which generated more such errors but it
was in an xterm that did not keep a complete history, so I only have a partial transcript.  I'll now attach both that transcript and the complete transcript of my last startx command.  
Since I can't use X (or who knows what else) on that machine (for which reason I'm  not using it to enter this), I'm raising the severity of this bug to high.
Comment 6 Donald Cohen 2009-05-31 17:12:04 EDT
Created attachment 346031 [details]
partial transcript of second yum update
Comment 7 Donald Cohen 2009-05-31 17:12:54 EDT
Created attachment 346032 [details]
attempt to startx
Comment 8 Andreas Schwab 2009-06-29 09:05:27 EDT
That looks very much like a corrupted file system, try running fsck.
Comment 9 Donald Cohen 2009-06-29 14:11:01 EDT
I eventually solved this problem (for myself, not for others) by moving to fc11.
So at this point I don't have a way to reproduce it.
I guess the bug can be closed.  I hope it can still be of some help to others if they experience similar problems.

Note You need to log in before you can comment on or make changes to this bug.