Bug 502402 - RFE: please deliver (and use!) filtering macros
RFE: please deliver (and use!) filtering macros
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-24 17:17 EDT by Chris Weyl
Modified: 2009-10-06 06:07 EDT (History)
6 users (show)

See Also:
Fixed In Version: 4:5.10.0-79
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-23 16:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec patch (2.19 KB, patch)
2009-05-24 17:17 EDT, Chris Weyl
no flags Details | Diff
macro file for /etc/rpm (1.76 KB, text/plain)
2009-05-24 17:18 EDT, Chris Weyl
no flags Details
localized macros; %included by perl.spec (1.81 KB, text/plain)
2009-05-24 17:19 EDT, Chris Weyl
no flags Details

  None (edit)
Description Chris Weyl 2009-05-24 17:17:14 EDT
Created attachment 345264 [details]
spec patch

arch-specific perl-* packages often have library provides picked up and exposed vi rpm's autoprov system, where it shouldn't; that is, these provides are useless, not in the system lib path, and will never be used for proper perl dependency resolution.  e.g. perl-YAML-Syck.i386 provides Syck.so(), mod_perl provides a slew of them, etc.

These macros will allow us to sensibly filter useless provides out:

    http://fedorapeople.org/~cweyl/macros.perl

The core perl package should deliver /etc/rpm/macros.perl, as above, and employ them to clean up its errant provides.  I've attached a patch that does that, as well as the additional %SOURCEs needed; a scratch build of the modifications has been run.

    http://koji.fedoraproject.org/koji/taskinfo?taskID=1375064

Thanks! :)
Comment 1 Chris Weyl 2009-05-24 17:18:23 EDT
Created attachment 345265 [details]
macro file for /etc/rpm
Comment 2 Chris Weyl 2009-05-24 17:19:05 EDT
Created attachment 345266 [details]
localized macros; %included by perl.spec
Comment 3 Chris Weyl 2009-08-03 02:52:55 EDT
Looks like the FPC and FESCo just approved 
https://fedoraproject.org/wiki/PackagingDrafts/AutoProvidesAndRequiresFiltering, so we can start thinking about delivering a Perl-specific one under /etc/rpm/macros.perl:

  http://fedorapeople.org/~cweyl/macros.perl

It's just a sensible default for perl-* packages, preventing private solib provides from showing up, as well as anything that may crop up under %_docdir.  Implemented as a single macro like this will enable us to use it as:

  %{?perl_default_filter}

...which will help prevent srpm breakage on other releases/distros that may not have these macros present.  Note that the %perl_default_filter is defined such that if the filtering macros aren't present on the system, the build will not fail.

Thoughts? :)
Comment 4 Chris Weyl 2009-08-23 16:58:55 EDT
In 4:5.10.0-79.
Comment 5 Fedora Update System 2009-09-18 16:22:07 EDT
perl-5.10.0-82.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/perl-5.10.0-82.fc11
Comment 6 Fedora Update System 2009-10-06 06:07:02 EDT
perl-5.10.0-82.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.