Bug 502414 - on-screen help facility
on-screen help facility
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-24 22:09 EDT by Jens Petersen
Modified: 2009-06-15 21:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.1.0.20090609-1.fc11
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:23:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-05-24 22:09:01 EDT
Description of problem:
IBus should provide on-screen help for how to use IMEs.
ibus can provide the mechanism to display basic howto help
from each IME.
Comment 1 Peng Huang 2009-05-25 02:28:47 EDT
How about create guides in html and open browser in ibus to show the guides?
Comment 2 Parag Nemade 2009-05-25 03:14:47 EDT
Is this help mean showing Key summary from keymap file like we used to show in scim?
Comment 3 Jens Petersen 2009-05-25 20:01:12 EDT
Adding Warren since he originally suggested this.

(In reply to comment #1)
> How about create guides in html and open browser in ibus to show the guides?  

Yeah that might work, or maybe something closer to scim's info screen?

(In reply to comment #2)
> Is this help mean showing Key summary from keymap file [...] ?

For m17n yes it could - it would depend on the IME.
Comment 4 Jens Petersen 2009-05-25 20:06:49 EDT
I think as long as any html is available locally, ie does not need an internet connection it would be ok anyway.
Comment 5 Fedora Update System 2009-06-09 19:47:54 EDT
ibus-1.1.0.20090609-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ibus-1.1.0.20090609-1.fc11
Comment 6 Fedora Update System 2009-06-15 21:23:02 EDT
ibus-1.1.0.20090609-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.