Bug 502443 - /usr/share/ocf/resource.d/heartbeat/.ocf-binaries sets $MAILCMD wrong
/usr/share/ocf/resource.d/heartbeat/.ocf-binaries sets $MAILCMD wrong
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: heartbeat (Show other bugs)
el5
All Linux
low Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 06:22 EDT by Robert Scheck
Modified: 2009-06-12 14:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 14:26:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-05-25 06:22:01 EDT
Description of problem:
/usr/share/ocf/resource.d/heartbeat/.ocf-binaries sets $MAILCMD wrong, change:

> : ${MAILCMD:=mailx}

please to:

> : ${MAILCMD:=mail}

Please do not use an absolute path, $PATH is available there. Issue also seems
to affect Rawhide.

Version-Release number of selected component (if applicable):
heartbeat-2.1.4-6.el5

How reproducible:
Everytime, see above.

Actual results:
/usr/share/ocf/resource.d/heartbeat/.ocf-binaries sets $MAILCMD wrong

Expected results:
Correct $MAILCMD set by /usr/share/ocf/resource.d/heartbeat/.ocf-binaries.
Comment 1 Kevin Fenzi 2009-06-06 01:41:19 EDT
I can change this, but why is 'mailx' wrong? Due to the added dependency on redhat-lsb?
Comment 2 Robert Scheck 2009-06-06 08:15:18 EDT
I did a "yum install heartbeat", no dependency here did mailx bring in:

# which mailx
/usr/bin/which: no mailx in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
# 

# rpm -q redhat-lsb
package redhat-lsb is not installed
# 

If redhat-lsb provides a symlink for mailx, it should be required, because
the package is not necessarily installed.
Comment 3 Kevin Fenzi 2009-06-06 17:13:04 EDT
Looks like just adding a 'BuildRequires: mailx' fixes this. It then sees /bin/mail as the right command and should work on both Fedora and EPEL. :) 

I will push this fix once the libnet stuff is ready.
Comment 5 Robert Scheck 2009-06-12 14:26:54 EDT
Yes, seems to work here. Thank you.

Note You need to log in before you can comment on or make changes to this bug.