Bug 502527 - Occasional failure to open drm device
Occasional failure to open drm device
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 17:09 EDT by Martin Ebourne
Modified: 2010-05-24 16:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 16:09:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log from boot with DRM failed (809.84 KB, text/plain)
2009-05-25 17:09 EDT, Martin Ebourne
no flags Details
Xorg log from boot where DRI worked (136.66 KB, text/plain)
2009-05-25 17:10 EDT, Martin Ebourne
no flags Details
Kernel log from boot with DRM failed (35.29 KB, text/plain)
2009-05-25 17:11 EDT, Martin Ebourne
no flags Details
Kernel log from boot where DRI worked (34.16 KB, text/plain)
2009-05-25 17:11 EDT, Martin Ebourne
no flags Details

  None (edit)
Description Martin Ebourne 2009-05-25 17:09:33 EDT
Created attachment 345353 [details]
Xorg log from boot with DRM failed

Description of problem:
Sometimes the driver fails to open the DRM device and disables DRI:
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.

Version-Release number of selected component (if applicable):
ATI Technologies Inc Radeon HD 3200 Graphics
xorg-x11-drv-ati-6.12.2-14.fc11.x86_64
2.6.29.3-155.fc11.x86_64

How reproducible:
Sometimes, perhaps 1 in 10. Once it's happened seems to need power off rather than just reboot to fix it.
Normally DRI does work.
Comment 1 Martin Ebourne 2009-05-25 17:10:33 EDT
Created attachment 345354 [details]
Xorg log from boot where DRI worked
Comment 2 Martin Ebourne 2009-05-25 17:11:25 EDT
Created attachment 345355 [details]
Kernel log from boot with DRM failed
Comment 3 Martin Ebourne 2009-05-25 17:11:55 EDT
Created attachment 345356 [details]
Kernel log from boot where DRI worked
Comment 4 Bug Zapper 2009-06-09 12:32:39 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Matěj Cepl 2009-11-05 13:29:52 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 6 Matěj Cepl 2010-02-26 07:25:06 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 7 Martin Ebourne 2010-03-21 22:05:59 EDT
This was still happening in F11 just recently. I've upgraded to F13 alpha now and will close this if I don't see it happen again.
Comment 8 Bug Zapper 2010-04-27 10:31:14 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Vedran Miletić 2010-05-24 16:09:14 EDT
Closing as worksforme per comment 13.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

[This triage is part of collective effort done by students of University of
Rijeka Department of Informatics.]
Comment 10 Vedran Miletić 2010-05-24 16:09:38 EDT
Typo: I was referring to comment 7.

Note You need to log in before you can comment on or make changes to this bug.