Bug 502541 - Firefox version should depend on Xulrunner but does not
Firefox version should depend on Xulrunner but does not
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 502787 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 21:47 EDT by Stephen Thorne
Modified: 2009-07-02 02:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 09:08:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Thorne 2009-05-25 21:47:33 EDT
Description of problem:

I selectively upgraded 'firefox' to firefox-3.5-0.20.beta4.fc11.x86_64 using 'yum install firefox'. Afterwards, firefox would not launch.

Version-Release number of selected component (if applicable):

Old version:
firefox-3.1-0.11.beta3.fc11.x86_64
xulrunner-devel-1.9.1-0.11.beta3.fc11.x86_64

New version:
firefox-3.5-0.20.beta4.fc11.x86_64
xulrunner-1.9.1-0.20.beta4.fc11.x86_64

How reproducible:

Steps to Reproduce:
1. Install xulrunner-1.9.1-0.11.beta3.fc11.x86_64 
2. Install firefox-3.5-0.20.beta4.fc11.x86_64
3. Run firefox
  
Actual results:

user@hostname$ firefox
Could not find compatible GRE between version 1.9.1b4 and 1.9.1b4.

Expected results:

Firefox launching.
Comment 2 Martin Stransky 2009-05-26 06:41:39 EDT
It's because xulrunner package provides gecko-devel-unstable = 1.9.1, not 1.9.1-0.20.beta4 which is requested by firefox.
Comment 3 Martin Stransky 2009-05-26 07:27:08 EDT
Fixed in firefox-3.5-0.21.beta4.fc11
Comment 4 Martin Stransky 2009-05-27 04:26:17 EDT
*** Bug 502787 has been marked as a duplicate of this bug. ***
Comment 5 Juan J. Cavallaro 2009-05-28 11:03:46 EDT
Same on x86 (32 bit)..
Comment 6 Mohammed Arafa 2009-07-02 02:56:20 EDT
current version firefox-3.5-0.20.beta4.fc11.x86_64 

i have this on 2 64bit machines and one has a working firefox and the other has the message

Note You need to log in before you can comment on or make changes to this bug.