Bug 502562 - /usr/bin/gpk-install-catalog does not seem to accept catalog files
/usr/bin/gpk-install-catalog does not seem to accept catalog files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 03:44 EDT by Traxtopel
Modified: 2009-06-15 22:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.27.2-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 04:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Traxtopel 2009-05-26 03:44:48 EDT
Not sure if something has changed since fedora 10.

Using gnome-packagekit-2.27.2-0.2.20090414git.fc11.i586.

Create a simple catalog file.

[PackageKit Catalog]
InstallPackages(fedora-11)=koules

As user.
/usr/bin/gpk-install-catalog test.catalog

Nothing happens, just returns the prompt.

Is the format I am using incorrect?
Comment 1 Richard Hughes 2009-05-26 04:38:55 EDT
(In reply to comment #0)
> Is the format I am using incorrect?  

Yes, in the session DBus rewrite I did recently, I forgot to expose InstallCatalogs on the session bus, apologies.

I'll release 2.27.2 in a few days and push it as an update to F11. Thanks.

---

commit 014d16c8525f2dd1fe43ece751b3c21a0ace6cd8
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue May 26 09:07:07 2009 +0100

    Export InstallCatalogs on the session bus. Fixes rh#502562

:100644 100644 c3b037b... 797fa40... M  src/gpk-dbus.c
:100644 100644 c99324c... ccab521... M  src/gpk-dbus.h
:100644 100644 5adc243... ca0ff05... M  src/org.freedesktop.PackageKit.xml

commit 57562db68e2c7c073dd7287f5336ed777d64e136
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue May 26 09:16:02 2009 +0100

    Don't show a long list of packages in the catalog install screen, instead use a scrollable package list

:100644 100644 51068ac... 33f5652... M  src/gpk-dbus-task.c
Comment 2 Fedora Update System 2009-06-01 06:57:15 EDT
gnome-packagekit-2.27.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnome-packagekit-2.27.2-1.fc11
Comment 3 Fedora Update System 2009-06-15 22:22:43 EDT
gnome-packagekit-2.27.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.