Bug 502590 - Please branch the latest vym for EL-5
Please branch the latest vym for EL-5
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: vym (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
PackageBranch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 06:59 EDT by Huzaifa S. Sidhpurwala
Modified: 2010-09-22 12:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 12:24:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2009-05-26 06:59:21 EDT
Please branch the latest vym for EL-5
Comment 1 Gwyn Ciesla 2009-05-26 09:28:07 EDT
My build dies.  Have you been able to build it on EL-5?

g++ -c -pipe -g -Wall -W -D_REENTRANT  -DVYM_DOCDIR=\"/usr/share/doc/vym-1.12.2\" -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include -I. -I. -o aboutdialog.o aboutdialog.cpp
g++ -c -pipe -g -Wall -W -D_REENTRANT  -DVYM_DOCDIR=\"/usr/share/doc/vym-1.12.2\" -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include -I. -I. -o animpoint.o animpoint.cpp
animpoint.cpp: In member function 'uint AnimPoint::getTicks()':
animpoint.cpp:91: warning: converting to 'uint' from 'qreal'
g++ -c -pipe -g -Wall -W -D_REENTRANT  -DVYM_DOCDIR=\"/usr/share/doc/vym-1.12.2\" -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include -I. -I. -o attribute.o attribute.cpp
attribute.cpp:185: warning: unused parameter 'v'
g++ -c -pipe -g -Wall -W -D_REENTRANT  -DVYM_DOCDIR=\"/usr/share/doc/vym-1.12.2\" -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include -I. -I. -o attributedelegate.o attributedelegate.cpp
g++ -c -pipe -g -Wall -W -D_REENTRANT  -DVYM_DOCDIR=\"/usr/share/doc/vym-1.12.2\" -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include -I. -I. -o attributedialog.o attributedialog.cpp
g++ -c -pipe -g -Wall -W -D_REENTRANT  -DVYM_DOCDIR=\"/usr/share/doc/vym-1.12.2\" -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include -I. -I. -o attributewidget.o attributewidget.cpp
g++ -c -pipe -g -Wall -W -D_REENTRANT  -DVYM_DOCDIR=\"/usr/share/doc/vym-1.12.2\" -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include -I. -I. -o branchobj.o branchobj.cpp
attributewidget.cpp:33: warning: unused parameter 't'
attributewidget.cpp:37: warning: unused parameter 't'
g++ -c -pipe -g -Wall -W -D_REENTRANT  -DVYM_DOCDIR=\"/usr/share/doc/vym-1.12.2\" -DQT_QT3SUPPORT_LIB -DQT3_SUPPORT -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt4/mkspecs/linux-g++ -I. -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtNetwork -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include -I. -I. -o branchpropwindow.o branchpropwindow.cpp
ui_branchpropwindow.h: In member function 'void Ui_BranchPropertyWindow::setupUi(QWidget*)':
ui_branchpropwindow.h:93: error: 'class QVBoxLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:94: error: 'class QVBoxLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:95: error: 'class QVBoxLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:96: error: 'class QVBoxLayout' has no member named 'setBottomMargin'
ui_branchpropwindow.h:144: error: 'class QVBoxLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:145: error: 'class QVBoxLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:146: error: 'class QVBoxLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:147: error: 'class QVBoxLayout' has no member named 'setBottomMargin'
ui_branchpropwindow.h:157: error: 'class QGridLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:158: error: 'class QGridLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:159: error: 'class QGridLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:160: error: 'class QGridLayout' has no member named 'setBottomMargin'
ui_branchpropwindow.h:161: error: 'class QGridLayout' has no member named 'setHorizontalSpacing'
ui_branchpropwindow.h:162: error: 'class QGridLayout' has no member named 'setVerticalSpacing'
ui_branchpropwindow.h:251: error: 'class QHBoxLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:252: error: 'class QHBoxLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:253: error: 'class QHBoxLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:254: error: 'class QHBoxLayout' has no member named 'setBottomMargin'
ui_branchpropwindow.h:283: error: 'class QHBoxLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:284: error: 'class QHBoxLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:285: error: 'class QHBoxLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:286: error: 'class QHBoxLayout' has no member named 'setBottomMargin'
ui_branchpropwindow.h: In member function 'void Ui_BranchPropertyWindow::setupUi(QWidget*)':
ui_branchpropwindow.h:93: error: 'class QVBoxLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:94: error: 'class QVBoxLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:95: error: 'class QVBoxLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:96: error: 'class QVBoxLayout' has no member named 'setBottomMargin'
ui_branchpropwindow.h:144: error: 'class QVBoxLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:145: error: 'class QVBoxLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:146: error: 'class QVBoxLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:147: error: 'class QVBoxLayout' has no member named 'setBottomMargin'
ui_branchpropwindow.h:157: error: 'class QGridLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:158: error: 'class QGridLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:159: error: 'class QGridLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:160: error: 'class QGridLayout' has no member named 'setBottomMargin'
ui_branchpropwindow.h:161: error: 'class QGridLayout' has no member named 'setHorizontalSpacing'
ui_branchpropwindow.h:162: error: 'class QGridLayout' has no member named 'setVerticalSpacing'
ui_branchpropwindow.h:251: error: 'class QHBoxLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:252: error: 'class QHBoxLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:253: error: 'class QHBoxLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:254: error: 'class QHBoxLayout' has no member named 'setBottomMargin'
ui_branchpropwindow.h:283: error: 'class QHBoxLayout' has no member named 'setLeftMargin'
ui_branchpropwindow.h:284: error: 'class QHBoxLayout' has no member named 'setTopMargin'
ui_branchpropwindow.h:285: error: 'class QHBoxLayout' has no member named 'setRightMargin'
ui_branchpropwindow.h:286: error: 'class QHBoxLayout' has no member named 'setBottomMargin'
make: *** [branchpropwindow.o] Error 1
make: *** Waiting for unfinished jobs....
ui_historywindow.h: In member function 'void Ui_HistoryWindow::setupUi(QDialog*)':
ui_historywindow.h:42: error: 'class QGridLayout' has no member named 'setLeftMargin'
ui_historywindow.h:43: error: 'class QGridLayout' has no member named 'setTopMargin'
ui_historywindow.h:44: error: 'class QGridLayout' has no member named 'setRightMargin'
ui_historywindow.h:45: error: 'class QGridLayout' has no member named 'setBottomMargin'
ui_historywindow.h:46: error: 'class QGridLayout' has no member named 'setHorizontalSpacing'
ui_historywindow.h:47: error: 'class QGridLayout' has no member named 'setVerticalSpacing'
ui_historywindow.h:74: error: 'class QHBoxLayout' has no member named 'setLeftMargin'
ui_historywindow.h:75: error: 'class QHBoxLayout' has no member named 'setTopMargin'
ui_historywindow.h:76: error: 'class QHBoxLayout' has no member named 'setRightMargin'
ui_historywindow.h:77: error: 'class QHBoxLayout' has no member named 'setBottomMargin'
make: *** [branchobj.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.84909 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.84909 (%build)
Comment 2 Mark Chappell 2010-09-22 12:24:53 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=110890

Looks like this got built last June and is now available in EPEL-5 closing off the ticket

Note You need to log in before you can comment on or make changes to this bug.