Bug 502598 - "Alias /download" overwrites /download for all virtualhosts
"Alias /download" overwrites /download for all virtualhosts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ocsinventory (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 08:02 EDT by Nerijus Baliūnas
Modified: 2009-05-26 11:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 11:31:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nerijus Baliūnas 2009-05-26 08:02:49 EDT
ocsinventory-reports-1.02-1.fc10.noarch has /etc/httpd/conf.d/ocsinventory-reports.conf, which includes:

# Deployment packages download area
#
Alias /download /var/lib/ocsinventory-reports/download

It "overwrites" /download, which is quite a popular URL part.
Comment 1 Remi Collet 2009-05-26 11:31:35 EDT
This is an upstream choice (perhaps not a best one)

All documentations refer to this URL.

Others distro also use this (debian, ...)

/etc/httpd/conf.d/ocsinventory-reports.conf provides a <VirtualHost> which is probably the best solution if the same server used for various applications (just need to be commented out).

Changing this to ocsdownload (p.e.) is really simple, and if the admin change it, he will not forget to change URL for package retrieval (which is not true if changed in the RPM).

So, this is not a bug.

If you think this a really a bug, please open a Upstream bug.

Note You need to log in before you can comment on or make changes to this bug.