Bug 50261 - kudzu hangs with usb enabled
kudzu hangs with usb enabled
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
David Lawrence
:
: 50262 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-29 12:47 EDT by Gene Czarcinski
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-31 20:06:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/modules.conf (83 bytes, text/plain)
2001-07-29 12:48 EDT, Gene Czarcinski
no flags Details
lspci (614 bytes, text/plain)
2001-07-29 12:49 EDT, Gene Czarcinski
no flags Details
lspci -v (2.21 KB, text/plain)
2001-07-29 12:49 EDT, Gene Czarcinski
no flags Details
lspci -vv (4.63 KB, text/plain)
2001-07-29 12:49 EDT, Gene Czarcinski
no flags Details
lspci -n (294 bytes, text/plain)
2001-07-29 12:50 EDT, Gene Czarcinski
no flags Details
lspci -nv (1.72 KB, text/plain)
2001-07-29 12:50 EDT, Gene Czarcinski
no flags Details
lsmod before modprobe (161 bytes, text/plain)
2001-07-30 04:28 EDT, Gene Czarcinski
no flags Details
lsmod after modprobe (336 bytes, text/plain)
2001-07-30 04:28 EDT, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2001-07-29 12:47:50 EDT
Description of Problem:

Install Roswell with onboard usb disable in the bios.  (diabled because
anaconda hangs if enabled, will report as separate problem).

After install, enable usb and booted the system.  System hung hard during
kudzo processing and hard reset required to reboot.

If I bootup and Interactively NOT run kudzu, the system comes up with usb
enabled.  I manually added the entry in /etc/modules.conf.

This is a TYAN Tiger 133 SMP motherboard with only ONE processor.

I will attach related files.

How Reproducible:
everytime

Steps to Reproduce:
1. see above
2.
3.

Actual Results:
System hung

Expected Results:
System boots

Additional Information:
Comment 1 Gene Czarcinski 2001-07-29 12:48:35 EDT
Created attachment 25313 [details]
/etc/modules.conf
Comment 2 Gene Czarcinski 2001-07-29 12:49:02 EDT
Created attachment 25314 [details]
lspci
Comment 3 Gene Czarcinski 2001-07-29 12:49:25 EDT
Created attachment 25315 [details]
lspci -v
Comment 4 Gene Czarcinski 2001-07-29 12:49:43 EDT
Created attachment 25316 [details]
lspci -vv
Comment 5 Gene Czarcinski 2001-07-29 12:50:01 EDT
Created attachment 25317 [details]
lspci -n
Comment 6 Gene Czarcinski 2001-07-29 12:50:22 EDT
Created attachment 25318 [details]
lspci -nv
Comment 7 Bill Nottingham 2001-07-30 00:24:26 EDT
What happens if you do 'modprobe usb-uhci' from the command line?
Comment 8 Bill Nottingham 2001-07-30 00:25:17 EDT
*** Bug 50262 has been marked as a duplicate of this bug. ***
Comment 9 Gene Czarcinski 2001-07-30 04:27:02 EDT
modprobe usb-usci works .. see attached lsmod output.

Comment 10 Gene Czarcinski 2001-07-30 04:28:07 EDT
Created attachment 25351 [details]
lsmod before modprobe
Comment 11 Gene Czarcinski 2001-07-30 04:28:37 EDT
Created attachment 25352 [details]
lsmod after modprobe
Comment 12 Gene Czarcinski 2001-07-30 04:29:54 EDT
Note:  no usb devices are attached to this system.
Comment 13 Bill Nottingham 2001-07-30 10:52:58 EDT
If, after boot, you run 'strace kudzu', where does it hang?
Comment 14 Glen Foster 2001-07-30 15:46:08 EDT
This defect is considered SHOULD-FIX for Fairfax
Comment 15 Gene Czarcinski 2001-07-31 00:54:50 EDT
Arrrgh!

Because of some hardware changes I made, I am currently unable to reproduce this
problem ... usb now initializes fine!

I swapped the motherboards between two systems and the problem went away.

The motherboard/configuration that was having the problem (TYAN) had an AGP
video adapter and a netgear NIC.  This same motherboard with a PCI video adapter
and a 3COM 905B NIC works fine now.

It will be a major headache to switch things back so I would prefer to drop this
but will give it a try if you folks want me to.

Over to you.
Comment 16 Bill Nottingham 2001-07-31 02:18:55 EDT
Well....

kudzu doesn't do anything that would crash the machine except load the
usb controller module. If that hangs the machine, it's a kernel bug.

So, assigning this to the kernel. They can decide whether they want yo
to try and reproduce it or not.
Comment 17 Gene Czarcinski 2001-07-31 02:41:57 EDT
The problem is that when the hang was occuring that I could manually modprobe
usb-uhci and it would work fine ... it only hung (hard reset needed) in kudzu or
in anaconda (which I assume used some kudzu code).
Comment 18 Pete Zaitcev 2001-07-31 20:06:05 EDT
Kudzu kills machines often because it removes modules.

This area was double problematic with USB because
USB has a separate thread (khubd) which is triggered
when HC driver loads. Then kudzu unloads module immediately
and khubd blows up.

I think I plugged all holes in hub.c for 7.1, but perhaps
something got regressed in new -ac kernels.

It may be possible to reproduce by running something
like this:

  set -e
  rmmod usb-uhci
  insmod usb-uhci && rmmod usb-uhci	# trips khubd

If anyone can reproduce this bug (or 50262), reopen!
I need to see it BEFORE WE FREEZE 7.2.

Note You need to log in before you can comment on or make changes to this bug.