Bug 502635 - --skip-broken shouldn't die on unsigned packages
--skip-broken shouldn't die on unsigned packages
Status: CLOSED DUPLICATE of bug 502277
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 11:32 EDT by joshua
Modified: 2014-01-21 18:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 11:39:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2009-05-26 11:32:41 EDT
Description of problem:

yum-3.2.22-4.fc11.noarch

[joshua@f11preview ~]$ sudo yum -y --skip-broken update
[sudo] password for joshua: 
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
updates/metalink                                         | 8.9 kB     00:00     
 * fedora: mirror.cc.vt.edu
 * rpmfusion-free: mirror.liberty.edu
 * rpmfusion-free-updates: mirror.liberty.edu
 * rpmfusion-nonfree: mirror.liberty.edu
 * rpmfusion-nonfree-updates: mirror.liberty.edu
 * updates: archive.linux.duke.edu
adobe-linux-i386                                         |  951 B     00:00     
rpmfusion-free-updates                                   | 3.3 kB     00:00     
rpmfusion-free-updates/primary_db                        | 364 kB     00:00     
rpmfusion-nonfree-updates                                | 3.3 kB     00:00     
rpmfusion-nonfree-updates/primary_db                     | 104 kB     00:00     
updates                                                  | 4.0 kB     00:00     
updates/primary_db                                       | 937 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ibus-m17n.x86_64 0:1.1.0.20090211-5.fc11 set to be updated
---> Package im-chooser.x86_64 0:1.2.6-3.fc11 set to be updated
---> Package iotop.noarch 0:0.3-1.fc11 set to be updated
---> Package lxsession-lite.x86_64 0:0.3.6-5.fc11 set to be updated
---> Package menu-cache.x86_64 0:0.2.5-1.fc11 set to be updated
---> Package policycoreutils.x86_64 0:2.0.62-12.5.fc11 set to be updated
---> Package policycoreutils-gui.x86_64 0:2.0.62-12.5.fc11 set to be updated
---> Package policycoreutils-python.x86_64 0:2.0.62-12.5.fc11 set to be updated
---> Package sugar-finance.noarch 0:3-1.fc11 set to be updated
---> Package tigervnc.x86_64 0:0.0.90-0.10.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                   Arch      Version                   Repository  Size
================================================================================
Updating:
 ibus-m17n                 x86_64    1.1.0.20090211-5.fc11     updates     27 k
 im-chooser                x86_64    1.2.6-3.fc11              updates     91 k
 iotop                     noarch    0.3-1.fc11                updates     46 k
 lxsession-lite            x86_64    0.3.6-5.fc11              updates     49 k
 menu-cache                x86_64    0.2.5-1.fc11              updates     68 k
 policycoreutils           x86_64    2.0.62-12.5.fc11          updates    942 k
 policycoreutils-gui       x86_64    2.0.62-12.5.fc11          updates    199 k
 policycoreutils-python    x86_64    2.0.62-12.5.fc11          updates    257 k
 sugar-finance             noarch    3-1.fc11                  updates    101 k
 tigervnc                  x86_64    0.0.90-0.10.fc11          fedora     261 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update      10 Package(s)         
Remove       0 Package(s)         

Total size: 2.0 M
Total download size: 1.7 M
Downloading Packages:
(1/9): ibus-m17n-1.1.0.20090211-5.fc11.x86_64.rpm        |  27 kB     00:00     
(2/9): im-chooser-1.2.6-3.fc11.x86_64.rpm                |  91 kB     00:00     
(3/9): iotop-0.3-1.fc11.noarch.rpm                       |  46 kB     00:00     
(4/9): lxsession-lite-0.3.6-5.fc11.x86_64.rpm            |  49 kB     00:00     
(5/9): menu-cache-0.2.5-1.fc11.x86_64.rpm                |  68 kB     00:00     
(6/9): policycoreutils-2.0.62-12.5.fc11.x86_64.rpm       | 942 kB     00:00     
(7/9): policycoreutils-gui-2.0.62-12.5.fc11.x86_64.rpm   | 199 kB     00:00     
(8/9): policycoreutils-python-2.0.62-12.5.fc11.x86_64.rp | 257 kB     00:00     
(9/9): sugar-finance-3-1.fc11.noarch.rpm                 | 101 kB     00:00     
--------------------------------------------------------------------------------
Total                                           1.1 MB/s | 1.7 MB     00:01     


Package tigervnc-0.0.90-0.10.fc11.x86_64.rpm is not signed

Version-Release number of selected component (if applicable):



--skip-broken shouldn't just die... the package not being signed *is broken*... it should just skip that package and move on!
Comment 1 seth vidal 2009-05-26 11:39:53 EDT

*** This bug has been marked as a duplicate of bug 502277 ***

Note You need to log in before you can comment on or make changes to this bug.