Bug 502644 - Unable to boot OpenSolaris Nevada (snv_114) with xen 3.3
Unable to boot OpenSolaris Nevada (snv_114) with xen 3.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Gerd Hoffmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 13:30 EDT by Ruben Kerkhof
Modified: 2009-10-05 08:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-05 08:31:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ruben Kerkhof 2009-05-26 13:30:13 EDT
Description of problem:
Booting a snv_114 domU with pygrub:
Error: Boot loader didn't return any data!

Version-Release number of selected component (if applicable):
xen-3.3.1-11

Additional info:
The zfs on-disk format changed with snv_114. The following changesets should allow booting with pygrub:

http://xenbits.xensource.com/xen-unstable.hg?rev/40e8684a34bf
http://xenbits.xensource.com/xen-unstable.hg?rev/3118041f2259
Comment 1 Gerd Hoffmann 2009-05-26 15:43:26 EDT
Already working on xen 3.4.0 update for rawhide (aka f12).

Dunno what to do best about f11.  Given that xen in f11 is very experimental anyway (needs a third-party kernel for starters ...) I tend to jump to 3.4 as well instead of cherry-picking more patches.
Comment 2 Mark McLoughlin 2009-05-26 16:34:16 EDT
(In reply to comment #1)
 
> Dunno what to do best about f11.  Given that xen in f11 is very experimental
> anyway (needs a third-party kernel for starters ...) I tend to jump to 3.4 as
> well instead of cherry-picking more patches.  

FWIW, that sounds reasonable to me - anyone using f11 as a dom0 surely can't be demanding complete stability
Comment 3 Ruben Kerkhof 2009-05-26 17:07:09 EDT
I totally agree, and will wait for xen 3.4. Thanks.
Comment 5 Ruben Kerkhof 2009-05-27 17:20:47 EDT
Thanks, I'll check them out!

One issue though:
[ruben@fikkie ~]$ sudo rpm -Uvh xen-*.rpm
Preparing...                ########################################### [100%]
	file /usr/share/info/configure.info.gz from install of xen-doc-3.4.0-1.fc12.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.x86_64
	file /usr/share/info/standards.info.gz from install of xen-doc-3.4.0-1.fc12.x86_64 conflicts with file from package binutils-2.19.51.0.2-17.fc11.x86_64
Comment 6 Bug Zapper 2009-06-09 12:35:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Ruben Kerkhof 2009-10-05 08:31:54 EDT
Thanks to the backports, I was able to install snv_123 successfully with xen-3.4.1-4. It even works with pygrub.

Note You need to log in before you can comment on or make changes to this bug.