Bug 50270 - gnome-print-0.29-1 creates /etc/gnome/fonts/fontmap2 without taking ownership of it
gnome-print-0.29-1 creates /etc/gnome/fonts/fontmap2 without taking ownership...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-print (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-29 14:12 EDT by Jonathan Kamens
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-29 09:44:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-07-29 14:12:55 EDT
The postinstall script from gnome-print creates /etc/gnome/fonts/fontmap2,
but its spec file doesn't know this.  Since this file is always created
when this package is installed, its spec file should take ownership of it
as a config file.
Comment 1 Owen Taylor 2001-07-30 14:52:53 EDT
A package can't take ownership of a file not distributed with it.

And if I distribute one file, the overwrite it in the install,
a .rpmsave file will always be created when upgrading -- not
a desirable consequence.

Doesn't seem much different to me than:

$ rpm -qf /etc/lilo.conf
file /etc/lilo.conf is not owned by any package
$ rpm -qf /etc/ld.so.cache 
file /etc/ld.so.cache is not owned by any package

So, my first instinct anyways is that it is OK the way it is.
Comment 2 Jonathan Kamens 2001-07-30 15:20:37 EDT
As a counter-example, see how /etc/rndc.conf is handled by the "bind" package.

/etc/lilo.conf is a bad example because the lilo package doesn't create
/etc/lilo.conf.  It's created by a human being, and therefore it's reasonable
for it not to be part of any package.

Similarly, /etc/ld.so.cache isn't created automatically by the installation of
any package.

On the other hand, the file referenced by this bug report is *always* created by
the package during installation, and thus should be claimed by the package.

To get around the .rpmsave problem you mentioned, you could either do what bind
does or have a preuninstall script that restores these files to their empty
contents so that the .rpmsave file won't be created during the upgrade.
Comment 3 Jonathan Kamens 2001-11-03 22:10:12 EST
I just upgraded to gnome-print-0.30-4, and now I've got another file that isn't
owned by any package -- /etc/gnome/fonts/gnome-print-rpm.fontmap.  This problem
is getting worse, not better :-).
Comment 4 Owen Taylor 2003-08-29 09:44:38 EDT
Actuallly, it's not worse, its still one file, just a different one.
(Yeah, when packages create files that aren't removed on upgrade,
it's hard to tell)

* Thu Aug 28 2003 Owen Taylor <otaylor@redhat.com> 1:0.37-7.1
- Ghost /etc/gnome/fonts/gnome-print-rpm.fontmap (#50270, Jonathan Kamens)


Note You need to log in before you can comment on or make changes to this bug.