Bug 502711 - notifications from catalog is not correct while someone updating the kbase information
notifications from catalog is not correct while someone updating the kbase in...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Mao DengFeng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 23:24 EDT by YangKun
Modified: 2009-08-27 13:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 13:47:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
replace the hard code with full url variable (1.49 KB, patch)
2009-07-28 03:46 EDT, Mao DengFeng
no flags Details | Diff

  None (edit)
Description YangKun 2009-05-26 23:24:18 EDT
Seems the notification emails sent by bugzilla/catalog is not correct while someone updating the kbase information. We updated the old kbase links today. the new kbase links start with "http://kbase.redhat.com/faq/docs/DOC-", but the bugzilla seems still using the old "templete" while sending out notification emails. For example, please take a look at following email, the old kbase is:   
    http://kbase.redhat.com/faq/show_bug.cgi?id=11855

we changed it to the new link:
    http://kbase.redhat.com/faq/docs/DOC-7784
in cert#462290(https://hardware.redhat.com/show.cgi?id=462290),

but the notification email from bugzilla says the new kbase link is:   
    http://kbase.redhat.com/faq/show_bug.cgi?id=7784
which points to a completely different page.

actually it's assassin(Anders) found out this problem. He was confused by the notification emails ;-)




-------- Original Message --------
Subject: 	[Bug 462290] HWCERT: Desktop Board Tower Case Prism Vx8600i
Date: 	Mon, 25 May 2009 05:58:30 -0400
From: 	bugzilla@redhat.com
To: 	ykun@redhat.com


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: HWCERT: Desktop Board Tower Case Prism Vx8600i


https://hardware.redhat.com/hwcert/show.cgi?id=462290


ykun@redhat.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
   External Bug URL|                            |http://kbase.redhat.com/faq/
                   |                            |show_bug.cgi?id=7784
   External Bug URL|http://kbase.redhat.com/faq/|
                   |show_bug.cgi?id=11855       |
    Customer Facing|---                         |
               Flag|                            |hwcert_work_specification_re
                   |                            |view+




-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
Comment 1 Rob Landry 2009-07-23 22:51:10 EDT
Tentative "+", if the fix is invasive it'll probably fall off.
Comment 2 Mao DengFeng 2009-07-27 03:34:26 EDT
Root cause:
  'show_bug.cgi?id=...' has been hard code in process.cgi like this:
======= code =============

                if (!$result) {
                    SendSQL("INSERT INTO ext_bz_bug_map (bug_id, ext_bz_id, ext_bz_bug_id) " .
                            "VALUES ($id, $extid, $extbugid)");
                    LogActivityEntry($id,"external_bugzilla.url","","$exturl/show_bug.cgi?id=$extbugid_noquote",$whoid,$timestamp);
                    $bug_changed = 1;
                }
======= code ==============
Comment 3 Mao DengFeng 2009-07-27 03:55:36 EDT
Solution:
 There is a 'full_url' field in the database 'external_bugzilla'. So we should change the hard codes to the 'full_url'
Comment 4 Mao DengFeng 2009-07-28 03:46:45 EDT
Created attachment 355367 [details]
replace the hard code with full url variable
Comment 5 Rob Landry 2009-07-28 14:33:17 EDT
How does the patch 355367 alter the email?  Is it a side effect of the log function?
Comment 6 Mao DengFeng 2009-07-28 21:53:42 EDT
(In reply to comment #5)
> How does the patch 355367 alter the email?  Is it a side effect of the log
> function?  

Right, the email will send out the difference and the difference are recorded by the log activity. we can look for something about this from approximate line 260 of CATALOG_ROOT/Bugzilla/BugMail.pm
Comment 7 XINSUN 2009-08-07 01:12:36 EDT
Patch has been committed.

Note You need to log in before you can comment on or make changes to this bug.