Bug 502807 - RFE: add a hint to the error message when adding unregistered email address
RFE: add a hint to the error message when adding unregistered email address
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.2
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 05:24 EDT by Karel Volný
Modified: 2013-06-23 22:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 11:07:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2009-05-27 05:24:28 EDT
Description of problem:
while reporting bug #502799, I have found that Bugzilla suffers the same problem - I cannot add "qe-baseos-daemons@redhat.com" to CC List

Version-Release number of selected component (if applicable):
3.2

How reproducible:


Steps to Reproduce:
1. When creating or modifying a bug, add "qe-baseos-daemons@redhat.com" to CC
  
Actual results:
the change is not saved and there is error message printed:

Red Hat Bugzilla was unable to make any match at all for one or more of the names and/or email addresses you entered on the previous page.
 Please go back and try other names or email addresses. 
  CC: 
  qe-baseos-daemons@redhat.com did not match anything


Expected results:
the change is saved, "qe-baseos-daemons@redhat.com" mailinglist is included in CC

Additional info:
I guess the root cause is the same as in bug #502799, however, I wonder if these are duplicates?
Comment 1 Noura El hawary 2009-05-27 06:14:12 EDT
Hi,

Lists can be added fine to the cclist of bugs in bugzilla, The problem here is that there is no bugzilla account for the mainling list 'qe-baseos-daemons@redhat.com', you need to create one for it using https://bugzilla.redhat.com/createaccount.cgi and please make sure that the list can receive email from bugzilla@redhat.com so you can get your account details and  bugzilla emails received successfully by the list.

Noura
Comment 2 Karel Volný 2009-05-27 09:26:05 EDT
Hi,

thankyou for the explanation, I wasn't aware of such a rule.

So before someone else runs in trouble too, let me reopen and change this to RFE - please change the error message to indicate better the cause of the problem. Let's say something like this:

Red Hat Bugzilla was unable to make any match at all for one or more of the
names and/or email addresses you entered on the previous page.
Please go back and try other names or email addresses. These have to correspond to an account registered in bugzilla.
Comment 3 David Lawrence 2009-05-27 11:07:10 EDT
The extra wording has been added to the error message and will be in the next code update.

Dave

Note You need to log in before you can comment on or make changes to this bug.