Bug 502833 - Intel 4965 card stops working under high load
Intel 4965 card stops working under high load
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 08:15 EDT by Jonathan Dieter
Modified: 2010-01-07 05:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-07 05:15:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
detailed messages from before and after the microcode crash (9.15 KB, application/octet-stream)
2009-05-27 08:15 EDT, Jonathan Dieter
no flags Details

  None (edit)
Description Jonathan Dieter 2009-05-27 08:15:37 EDT
Created attachment 345602 [details]
detailed messages from before and after the microcode crash

Description of problem:
I have two identical Lenovo X61 laptops running up-to-date Rawhide (which will be F11 in five days).  On one of them, the Intel 4965 wireless card stops working when a large amount of data (between 200MB and 1GB) is transmitted over the wireless network.  I've enabled debugging on the iwlagn card (debug=0x43ff) and am attaching the logs.  It seems as if it might be temperature related, though the working laptop has no problems with reported temperatures of up to 65C.

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.29.3-155.fc11.i686

How reproducible:
Always

Steps to Reproduce:
1. Try to copy a large file over the network
  
Actual results:
After 200MB to 1GB, data stops being transferred and a "Microcode SW error" appears in the logs

Expected results:
Working wifi

Additional info:
Both laptops have 4965AG-MM1 cards and I've really stress-tested the working laptop, but cannot get its wireless to stop working.  It almost seems as if it's hardware, but both laptops are brand new and were running fine under Windows Vista (though a bit sluggishly).
Comment 1 Bernie Innocenti 2009-05-31 15:55:58 EDT
This bug has been recently fixed upstream, please backport the bugfix:

  http://bugzilla.kernel.org/show_bug.cgi?id=12595
Comment 2 Jonathan Dieter 2009-06-03 10:35:17 EDT
I'm not convinced it's the same error; the error messages in the log are slightly different from yours.  I've opened an upstream bug:

http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=2013

On a side note, the working laptop's wireless finally died with the same error message.  Manually shutting down the wireless using the hardware switch and turning it on again fixed the problem.

It would seem to me that there's some kind of hardware weakness that is somehow exposed by the Linux driver and not the Windows driver.  A minor difference in the cards' thermostats is perhaps the reason that one rarely thinks it is overheating, and when it does, recovers quickly, while the other often thinks it is overheating and only recovers for a minute or two before dying again.
Comment 3 Bug Zapper 2009-06-09 12:38:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jonathan Dieter 2009-06-09 13:46:16 EDT
Ok, that's weird.  I turned on power management for the non-working laptop, and, even though the wifi card temperature didn't go above 54C, the wireless *still* died after ten minutes.
Comment 5 reinette chatre 2009-07-07 14:25:08 EDT
(In reply to comment #2)
> I'm not convinced it's the same error; the error messages in the log are
> slightly different from yours.  I've opened an upstream bug:
> 
> http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=2013
> 

So far no response from reporter to a request (on 6/16) for information in this bug report.
Comment 6 Jonathan Dieter 2009-07-07 15:14:53 EDT
Sorry for the delay.  I've replied upstream.  My wife has been using a USB wifi stick and I lost track of the bug report.
Comment 7 Jonathan Dieter 2009-07-10 14:49:11 EDT
This bug is a hardware fault, so upstream has closed as INVALID.
Comment 8 Jonathan Dieter 2009-07-12 10:16:46 EDT
Commit e4da4beafa550c289fa91e06c0909c003351f148 in kernel-PAE-2.6.31-0.62.rc2.git4.fc12.i686.rpm has automatic recovery from hardware failure (see http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=2013#c9).  Any chance that this commit could get pushed to 2.6.29 or 2.6.30 for F11?
Comment 9 Stanislaw Gruszka 2010-01-07 05:15:44 EST
I'm sorry, I have no time to backport this. Soon fedora F11 will switch to 2.6.32. As F12 is using 2.6.32 now, I'm closing this bug with NEXT RELEASE resolution.
Comment 10 Jonathan Dieter 2010-01-07 05:22:25 EST
No problem, I've already upgraded to F12 and replace my wife's wifi adapter.

Note You need to log in before you can comment on or make changes to this bug.