Bug 502879 - Current remote-configuration for EC2E won't work with multiple hook keywords
Current remote-configuration for EC2E won't work with multiple hook keywords
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
Development
All Linux
high Severity high
: 1.2
: ---
Assigned To: Robert Rati
Luigi Toscano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 11:28 EDT by Robert Rati
Modified: 2010-03-16 10:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-16 10:30:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2009-05-27 11:28:38 EDT
Description of problem:
The configuration file provided for EC2E hooks won't work once the multiple hook keywords makes it into a condor build.  This is because the configuration file does not define a hook keyword which is required for the hooks to run.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2009-09-17 16:17:00 EDT
Fixed in:
condor-remote-configuration-1.0-17
Comment 3 Luigi Toscano 2009-11-05 06:58:24 EST
The configuration generated by condor_configure_node now defines configuration keys for EC2 using a separate keyword and set it as the JOB_ROUTER_HOOK_KEYWORD.

Verified on RHEL5.4, i386/x86_64, condor-remote-configuration-1.0-23.

Changing the status to VERIFIED.
Comment 4 Jeff Needle 2010-03-16 10:30:27 EDT
The fix for this bug was included in the MRG 1.2 release.
Comment 5 Jeff Needle 2010-03-16 10:35:29 EDT
The fix for this bug was included in the MRG 1.2 release.

Note You need to log in before you can comment on or make changes to this bug.