Bug 502880 - Job Router hook keyword should apply to ATTRS_TO_COPY
Job Router hook keyword should apply to ATTRS_TO_COPY
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
Development
All Linux
low Severity medium
: 1.2
: ---
Assigned To: Robert Rati
Luigi Toscano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 11:31 EDT by Robert Rati
Modified: 2010-03-16 10:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-16 10:32:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2009-05-27 11:31:29 EDT
Description of problem:
Since multiple sets of hooks are allowed via hook keywords, the JOB_ROUTER_ATTRS_TO_COPY should really be attached to a set of hooks as it's possible not all hooks would have all attrs listed in JOB_ROUTER_ATTRS_TO_COPY available to copy.  Doing so would also reduce the likelihood of a custom attr being copied for a set of hooks that isn't expecting it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2009-07-24 12:42:59 EDT
JOB_ROUTER_ATTRS_TO_COPY is now <hook_keyword>_ATTRS_TO_COPY, so the custom attributes copied from the routed job will be linked to the hook keyword and therefore the hooks used for the job.

Fixed in build after:
condor-7.3.2-0.4
Comment 3 Luigi Toscano 2009-11-12 12:54:35 EST
ATTRS_TO_COPY is now associated to a set of hooks (foo_ATTRS_TO_COPY, bar_ATTRS_TO_COPY). The listed attributes are correctly passed from the routed job to the original job when the update_status hook is triggered.

Tested on RHEL 4.8/5.4, i386/x86_64.
condor-7.4.1-0.5
python-condor-job-hooks-common-1.0-13
condor-job-hooks-1.0-13

Changing the status to VERIFIED.
Comment 4 Jeff Needle 2010-03-16 10:32:26 EDT
The fix for this bug was included in the MRG 1.2 release.
Comment 5 Jeff Needle 2010-03-16 10:35:44 EDT
The fix for this bug was included in the MRG 1.2 release.

Note You need to log in before you can comment on or make changes to this bug.