Bug 502883 - towhee fails to build: operand out of range error
towhee fails to build: operand out of range error
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 11:49 EDT by Susi Lehtola
Modified: 2009-07-22 18:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 18:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Susi Lehtola 2009-05-27 11:49:41 EDT
Build of towhee fails due to

{standard input}:280865: Error: operand out of range (0x0000000000008008 is not between 0xffffffffffff8000 and 0x0000000000007fff)

both on F10 and F11 on ppc64 architecture, see

http://koji.fedoraproject.org/koji/getfile?taskID=1379583&name=build.log
http://koji.fedoraproject.org/koji/getfile?taskID=1379646&name=build.log

The object files that are to be linked are 13k and 82k on x86_64 architecture, so it shouldn't fail on too big a file.

On EL5 the package builds fine (no ppc64 architecture).
Comment 1 Bug Zapper 2009-06-09 12:39:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jakub Jelinek 2009-06-16 11:15:09 EDT
Try -mminimal-toc or splitting the sources.  It is not about size of object files, but a TOC section overflow.
Comment 3 Susi Lehtola 2009-07-22 18:38:40 EDT
-mminimal-toc doesn't work. I've excluded ppc64 for now. Closing.

Note You need to log in before you can comment on or make changes to this bug.