Bug 502896 - virtinst should support kvm-img and qemu-img
virtinst should support kvm-img and qemu-img
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virtinst (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 12:36 EDT by Doug Goldstein
Modified: 2010-03-16 13:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 12:28:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
virtinst-0.400.3-kvm-img.patch (1.03 KB, patch)
2009-05-27 12:36 EDT, Doug Goldstein
no flags Details | Diff

  None (edit)
Description Doug Goldstein 2009-05-27 12:36:58 EDT
Created attachment 345648 [details]
virtinst-0.400.3-kvm-img.patch

Description of problem:

virtinst relies on qemu-img to exist at runtime. Several distros install all of kvm with the utilities prefixed as kvm- so that there's not a file collision when installing qemu.

Attached is a patch that should make it work in those cases.
Comment 1 Cole Robinson 2009-05-27 12:42:05 EDT
Huh, good to know.

I would also recommend you file a bug against libvirt for the same issue: libvirt storage APIs use qemu-img for all non-raw provisioning. It should be as simple as changing the configure script to look for kvm-img as well.
Comment 2 Doug Goldstein 2009-05-27 13:19:50 EDT
Will do Cole. I'm actually in the process of writing the patch for libvirt. It's a little bit more involved since I'm refactoring some code to support a few of the /* XXX: Need to support this when qemu-img does */ sections because kvm-img actually supports those features.
Comment 3 Cole Robinson 2009-06-09 12:28:08 EDT
Thanks, pushed now:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/89c9f3ece3fb

Closing as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.