Bug 502910 - Provisioning, unable to provision xen guest, "Virtual kickstart failed. Koan error.: File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py"
Provisioning, unable to provision xen guest, "Virtual kickstart failed. Koan ...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
https://grandprix.rhndev.redhat.com/r...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 13:55 EDT by wes hayutin
Modified: 2009-05-28 15:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-28 10:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-05-27 13:55:56 EDT
Description of problem:

5/21.1

Provisioning, unable to provision xen guest, "Virtual kickstart failed. Koan error.: File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py"

recreate:

1. register a virt host to satellite
2. kick off a rhel 5 xen guest ks

get 

This action's status is: Failed.
The client picked up this action on 05/27/09 1:38:01 PM EDT.
The client completed this action on 05/27/09 1:39:50 PM EDT.
Client execution returned "Virtual kickstart failed. Koan error.: File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 129, in initiate_guest k.run() File "/usr/lib/python2.4/site-packages/koan/app.py", line 296, in run self.virt() File "/usr/lib/python2.4/site-packages/koan/app.py", line 584, in virt return self.net_install(after_download) File "/usr/lib/python2.4/site-packages/koan/app.py", line 503, in net_install after_download(self, profile_data) File "/usr/lib/python2.4/site-packages/koan/app.py", line 582, in after_download self.virt_net_install(profile_data) File "/usr/lib/python2.4/site-packages/koan/app.py", line 1051, in virt_net_install virt_type = self.virt_type File "/usr/lib/python2.4/site-packages/koan/xencreate.py", line 177, in start_install guest.start_install() File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 822, in start_install return self._do_install(consolecb, meter, wait) File "/usr/lib/python2.4/site-packages/virtinst/Guest.py" (code 1)


error on client:


url=http://grandprix.rhndev.redhat.com/cobbler/images/ks-rhel-i386-server-5-u3:xen/initrd.img
- reading URL: http://grandprix.rhndev.redhat.com/cobbler/images/ks-rhel-i386-server-5-u3:xen/initrd.img
downloading kernel vmlinuz to /var/lib/xen/vmlinuz
url=http://grandprix.rhndev.redhat.com/cobbler/images/ks-rhel-i386-server-5-u3:xen/vmlinuz
- reading URL: http://grandprix.rhndev.redhat.com/cobbler/images/ks-rhel-i386-server-5-u3:xen/vmlinuz
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByUUID
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByName
libvir: Xen Daemon error : POST operation failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not working.')
libvirt.libvirtError
virDomainCreateLinux() failed POST operation failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not working.')
  File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 129, in initiate_guest
    k.run()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 296, in run
    self.virt()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 584, in virt
    return self.net_install(after_download)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 503, in net_install
    after_download(self, profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 582, in after_download
    self.virt_net_install(profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 1051, in virt_net_install
    virt_type     =  self.virt_type
   File "/usr/lib/python2.4/site-packages/koan/xencreate.py", line 177, in start_install
    guest.start_install()
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 822, in start_install
    return self._do_install(consolecb, meter, wait)
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 843, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
   File "/usr/lib/python2.4/site-packages/libvirt.py", line 573, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)

D: Sending back response (1, 'Virtual kickstart failed. Koan error.', {'koan': '  File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 129, in initiate_guest\n    k.run()\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 296, in run\n    self.virt()\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 584, in virt\n    return self.net_install(after_download)\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 503, in net_install\n    after_download(self, profile_data)\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 582, in after_download\n    self.virt_net_install(profile_data)\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 1051, in virt_net_install\n    virt_type     =  self.virt_type\n   File "/usr/lib/python2.4/site-packages/koan/xencreate.py", line 177, in start_install\n    guest.start_install()\n   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 822, in start_install\n    return self._do_install(consolecb, meter, wait)\n   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 843, in _do_install\n    self.domain = self.conn.createLinux(install_xml, 0)\n   File "/usr/lib/python2.4/site-packages/libvirt.py", line 573, in createLinux\n    if ret is None:raise libvirtError(\'virDomainCreateLinux() failed\', conn=self)\n'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: Called refresh_rpmlist
Updating package profile
D: local action status:  (0, 'rpmlist refreshed', {})
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
Comment 1 Justin Sherrill 2009-05-28 10:53:20 EDT
the problem is just that the virt host doesn't have  xenbr0 as a bridge, it has xenbr2.  If you set the guest to use xenbr2 in the advanced page, it works fine.

Note You need to log in before you can comment on or make changes to this bug.