Bug 502914 - QMF Console (C++) does not always shut down cleanly.
QMF Console (C++) does not always shut down cleanly.
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1.1
All Linux
low Severity medium
: 1.1.2
: ---
Assigned To: Ted Ross
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 14:52 EDT by Ted Ross
Modified: 2015-11-15 19:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-12 13:39:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (off of svn revision 752581) that fixes this problem. (11.74 KB, patch)
2009-06-08 12:55 EDT, Ted Ross
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1097 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging bug fixing update 2009-06-12 13:38:48 EDT

  None (edit)
Description Ted Ross 2009-05-27 14:52:04 EDT
Description of problem:

When an application using the C++ QMF Console API is shut down (via signal), it will occasionally cause a crash due to unorderly destruction of resources.


Version-Release number of selected component (if applicable):

1.1.1

How reproducible:

unknown
Comment 1 Ted Ross 2009-06-08 12:55:19 EDT
Created attachment 346897 [details]
Patch (off of svn revision 752581) that fixes this problem.
Comment 2 Ted Ross 2009-06-09 09:02:43 EDT
How to reproduce:

You need the following example from svn revision 782981 (or later):

cpp/examples/qmf-console/printevents

If you start this example program (it connects to localhost:5672) against a running broker (use --auth no to make it simple), and interrupt the program with a SIGINT (control-C), it will coredump in the failure case and close cleanly in the success case.

-Ted
Comment 3 Gordon Sim 2009-06-09 09:06:55 EDT
Fixed in qmf-0.5.752581-13.el5
Comment 6 Frantisek Reznicek 2009-06-10 02:36:58 EDT
Putting back to ON_QA.
Comment 7 Frantisek Reznicek 2009-06-10 10:04:06 EDT
The issue has been fixed. Validated on RHEL 4.7 / 5.3 i386 / x86_64 on packages:
[root@dell-pe-sc1435-02 bz502914]# rpm -qa | egrep '(rhm|qpid|openais)' | sort -u
openais-0.80.3-22.el5_3.7
openais-debuginfo-0.80.3-22.el5_3.7
openais-devel-0.80.3-22.el5_3.7
python-qpid-0.5.752581-2.el5
qpidc-0.5.752581-14.el5
qpidc-debuginfo-0.5.752581-14.el5
qpidc-devel-0.5.752581-14.el5
qpidc-perftest-0.5.752581-14.el5
qpidc-rdma-0.5.752581-14.el5
qpidc-ssl-0.5.752581-14.el5
qpidd-0.5.752581-14.el5
qpidd-acl-0.5.752581-14.el5
qpidd-cluster-0.5.752581-14.el5
qpidd-devel-0.5.752581-14.el5
qpid-dotnet-0.4.738274-2.el5
qpidd-rdma-0.5.752581-14.el5
qpidd-ssl-0.5.752581-14.el5
qpidd-xml-0.5.752581-14.el5
qpid-java-client-0.5.751061-7.el5
qpid-java-common-0.5.751061-7.el5
rhm-0.5.3206-1.el5
rhm-docs-0.5.756148-1.el5


->VERIFIED


Note: I suceeded to create robust reproducer using parallel run of recommended cleint.
Comment 9 errata-xmlrpc 2009-06-12 13:39:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1097.html

Note You need to log in before you can comment on or make changes to this bug.