Bug 502921 - error: failed to stat /dev/shm: No such file or directory
error: failed to stat /dev/shm: No such file or directory
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 528777 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 15:27 EDT by Chris Shoemaker
Modified: 2010-05-11 19:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 14:31:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Shoemaker 2009-05-27 15:27:28 EDT
While running rpm inside the %post section of my livecd kickstart file...

My %post section starts out:
%post
#!/bin/bash
export PATH

# See bug 496961
rm -f /var/lib/rpm/__db.00*

# just until these packages make it into updates.
# have to force because of conflict with old gstreamer-plugins-bad
# see https://bugzilla.rpmfusion.org/show_bug.cgi?id=622
rpm -Uvh http://kojipkgs.fedoraproject.org/packages/gstreamer/0.10.23/1.fc11/x86_64/gstreamer-tools-0.10.23-1.fc11.x86_64.rpm http://kojipkgs.fedoraproject.org/packages/gstreamer/0.10.23/1.fc11/x86_64/gstreamer-0.10.23-1.fc11.x86_64.rpm --force

..........

And during livecd-creator, I see:

Retrieving http://kojipkgs.fedoraproject.org/packages/gstreamer/0.10.23/1.fc11/x86_64/gstreamer-tools-0.10.23-1.fc11.x86_64.rpm
Retrieving http://kojipkgs.fedoraproject.org/packages/gstreamer/0.10.23/1.fc11/x86_64/gstreamer-0.10.23-1.fc11.x86_64.rpm
error: failed to stat /dev/shm: No such file or directory
Preparing...                ########################################### [100%]
   1:gstreamer-tools        ########################################### [ 50%]
   2:gstreamer              ########################################### [100%]

I don't notice any adverse effects from the error message.

I've got: anaconda-11.5.0.54-1.fc11.x86_64
and: rpm-4.7.0-1.fc11.x86_64
and: livecd-tools-024-1.fc11.x86_64
Comment 1 Chris Lumens 2009-05-27 16:04:15 EDT
Can you attach /tmp/storage.log and /tmp/anaconda.log to this bug report?  These files are copied into /var/log post-install so you can grab them from there if you've got the install done.
Comment 2 Chris Shoemaker 2009-05-28 15:24:47 EDT
I'm confused.  This happens during livecd-creator.  I don't see any storage.log or anaconda.log either inside or outside the chroot.
Comment 3 Chris Lumens 2009-05-28 15:29:18 EDT
If it happens during livecd-creator, why's this bug filed against anaconda?
Comment 4 Chris Shoemaker 2009-05-28 15:42:28 EDT
Sorry, I got confused by the similarity to #490772.
Comment 5 Bug Zapper 2009-06-09 12:40:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Jeremy Katz 2009-06-09 15:16:07 EDT
Not a huge deal as rpm will fallback to non-shm methods, but pushed the fix to bind mount /dev/shm into the live image build process to git master
Comment 7 Jeremy Katz 2009-07-21 14:31:39 EDT
Closing out bug that's been in MODIFIED for a while.
Comment 8 Joey Boggs 2010-05-11 19:00:31 EDT
*** Bug 528777 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.