Bug 502939 - Bad behaviour of gnome-terminal opening new tab
Bad behaviour of gnome-terminal opening new tab
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 16:49 EDT by Need Real Name
Modified: 2010-01-06 09:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-06 09:50:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2009-05-27 16:49:47 EDT
gnome-terminal has some very odd - and potentially dangerous behaviour.

Say you have a terminal open, and open a new tab. It will open a new tab in the same directory as the first.

Except it doesn't always, which could mean you run commands based on that false assumption.

"rm -rf tmp" in the wrong directory might be a BIG problem.

An example:

Tab 1: find /
open new tab
Tab 2: we get whatever directory find is currently searching through

This is a potential data loss bug caused by inconsistent behaviour. This is also a regression from F9 afair.

(is this $PWD versus /proc/cwd?)
Comment 1 Will Woods 2009-05-27 17:11:15 EDT
See bug 496947 and upstream bug here: http://bugzilla.gnome.org/show_bug.cgi?id=565328
Comment 2 Bug Zapper 2009-06-09 12:41:20 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.