Bug 502942 - Strange behaviour when changing volume using new volume applet
Strange behaviour when changing volume using new volume applet
Status: CLOSED DUPLICATE of bug 545447
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
12
i386 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 17:02 EDT by markm
Modified: 2009-12-12 09:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-12 09:22:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markm 2009-05-27 17:02:26 EDT
Description of problem:

1. when I listen to the music, it gets cracked from time to time, it rewinds by 2 seconds from time to time, it breaks for a second or two from time to time - overall my experience is very poor.

2. What has happened to the volume control? it doesn't work correctly either. When I change volume in rhythmbox to 80%, then move a volume slider in volume applet, rhythmbox shows 20%, but plays as if 80%, same with totem.

before it was much simpler - one master volume, and one per application - now every application takes over master, when I change volume in the application

Version-Release number of selected component (if applicable):

[marek@Mareg Desktop]$ rpm -qa | grep pulseaudio
xine-lib-pulseaudio-1.1.16.3-2.fc11.i586
pulseaudio-module-x11-0.9.15-11.fc11.i586
wine-pulseaudio-1.1.18-1.fc11.i586
pulseaudio-libs-0.9.15-11.fc11.i586
pulseaudio-libs-glib2-0.9.15-11.fc11.i586
pulseaudio-module-gconf-0.9.15-11.fc11.i586
alsa-plugins-pulseaudio-1.0.18-3.fc11.i586
pulseaudio-utils-0.9.15-11.fc11.i586
pulseaudio-0.9.15-11.fc11.i586
pulseaudio-module-bluetooth-0.9.15-11.fc11.i586

Steps to Reproduce:
1. start rythmbox, adjust volume
2. start totem, adjust volume
3. open volume applet, change volume
  
Actual results:

changing volume per application changes master volume

Expected results:

master volume stays untouched, while application remembers per application volume setting

Additional info:
Comment 1 Bug Zapper 2009-06-09 12:41:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 joshua 2009-07-31 00:41:47 EDT
Same problems here... why did audio control get so much worse in F11 than the way it was in F10?
Comment 3 MuadNu 2009-08-04 16:59:45 EDT
Same here, running F11 x86_64 on an Acer Timeline 3810T.
Comment 4 Lennart Poettering 2009-08-19 11:45:45 EDT
Which driver is this? Please provide contents of /proc/asound/pcm and /proc/asound/cards.

Please post seperate issues seperately. I'll ignore the rb issues here.
Comment 5 markm 2009-08-19 12:03:05 EDT
(In reply to comment #4)
> Which driver is this? Please provide contents of /proc/asound/pcm and
> /proc/asound/cards.

I am at work right now, so will provide this information later in the evening.

> Please post seperate issues seperately. I'll ignore the rb issues here.  

I doubt it's a rhythmbox's issue - rhythmbox here was just an example application, which I am using the most - totem has the same issue - when I open a browser and go to the youtube.com to play any flash video, same issue. So please don't be rude - I am just trying to help to solve the issue.
Comment 6 Lennart Poettering 2009-08-19 13:00:05 EDT
Still, please file seperate issues seperately.
Comment 7 MuadNu 2009-08-19 13:13:43 EDT
Here are mine:

$ cat /proc/asound/pcm
00-00: ALC269 Analog : ALC269 Analog : playback 1 : capture 1
00-01: ALC269 Digital : ALC269 Digital : playback 1
00-03: INTEL HDMI : INTEL HDMI : playback 1

$ cat /proc/asound/cards 
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xe4500000 irq 22
Comment 8 markm 2009-08-19 18:48:00 EDT
Here are mine:

# cat /proc/asound/pcm 
00-00: STAC92xx Analog : STAC92xx Analog : playback 1 : capture 1
00-01: STAC92xx Digital : STAC92xx Digital : playback 1

# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xefffc000 irq 21
Comment 9 markm 2009-08-22 15:03:04 EDT
I must say, after latest update it got much worse, I can hear crackles and noises or have sound skipped almost with every song I play now. Really annoying.

Is it connected to the PolicyKit and the fact pulseaudio doesn't have access to real-time scheduling?
Comment 10 Adam Williamson 2009-10-20 14:53:08 EDT
another kernel issue, Lennart?

reporter, if you have a few minutes, can you test with Fedora 12 Beta and see if it happens there? just for information. thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Brad Smith 2009-10-21 17:32:20 EDT
I also encounter the problem of linked application volume controls and master volume control. I constantly forget to turn the hardware volume control to off before twiddling the volume control in Rhythmbox (for example) and getting blasted off my chair with extremely (excruciating) loud audio.
Comment 12 markm 2009-12-10 06:11:07 EST
(In reply to comment #10)
> another kernel issue, Lennart?
> 
> reporter, if you have a few minutes, can you test with Fedora 12 Beta and see
> if it happens there? just for information. thanks.

I have just reported a bug against Fedora 12: https://bugzilla.redhat.com/show_bug.cgi?id=545447 - still can hear noises and crackles, less then on Fedora 11, but more predictable, examples:

 * when rhythmbox stops playing, I get noise at 100% of volume for a fraction of the second
 * when I have rhythmbox playing and I navigate to the website with flash, I can hear loud noise for a fraction of the second too
 * crossfader in rhythmbox doesn't work and gives noise from time to time too
Comment 13 Adam Williamson 2009-12-11 17:00:17 EST
do you want to close this one and pursue the other one instead, then?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 markm 2009-12-12 09:22:09 EST
(In reply to comment #13)
> do you want to close this one and pursue the other one instead, then?

yep, we can close that one... though I would prefer to have my sound fixed ;-)

*** This bug has been marked as a duplicate of bug 545447 ***

Note You need to log in before you can comment on or make changes to this bug.