Bug 502958 - sat 5.3.0 installation on rhel4- s390x fails with EOFError
sat 5.3.0 installation on rhel4- s390x fails with EOFError
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Sayli Karmarkar
:
Depends On:
Blocks: 456985 468153
  Show dependency treegraph
 
Reported: 2009-05-27 18:35 EDT by Sayli Karmarkar
Modified: 2015-03-22 21:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:37:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn-installation.log (87.31 KB, text/plain)
2009-05-27 18:40 EDT, Sayli Karmarkar
no flags Details
new rhn-installation.log (8.42 KB, text/plain)
2009-06-11 19:37 EDT, Sayli Karmarkar
no flags Details
log with error using yum (9.02 KB, application/x-troff-man)
2009-06-15 11:36 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Sayli Karmarkar 2009-05-27 18:35:47 EDT
Description of problem:

1. Registered s390x rhel4 box (reserved from rhts) to webqa. 
2. Downloaded Satellite-5.3.0-RHEL4-re20090521.1-s390x-embedded-oracle.iso, cert and answers.txt
4. cd /mnt/iso-location
3. ./install.pl --answer-file=/root/answers.txt

Actual results:
[root@z209 satiso]# ./install.pl --answer-file=/root/answers.txt
* Starting the Red Hat Network Satellite installer.
* Loading answer file: /root/answers.txt.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHN Registration.
** Registration: System is already registered with RHN.  Not re-registering.
* Checking for uninstalled prerequisites.
* Applying updates.
* Installing RHN packages.
Could not install RHN packages.  Most likely your system is not configured with the @Base package group.  See the RHN Satellite Server Installation Guide for more information about Software Requirements.  Exit value: 1.

Expected results:
No error

Additional info:
/var/log/rhn/rhn-installation.log shows:

....

  Install: wsdl4j.noarch 0:1.6.2-1jpp.ep1.8 - Satellite/wsdl4j-1.6.2-1jpp.ep1.8.noarch.rpm
  Install: xalan-j2.noarch 0:2.7.0-2jpp.ep1.3 - Satellite/xalan-j2-2.7.0-2jpp.ep1.3.noarch.rpm
  Install: xerces-j2.noarch 0:2.7.1-9jpp.ep1.1 - Satellite/xerces-j2-2.7.1-9jpp.ep1.1.noarch.rpm
  Install: xml-commons.noarch 0:1.3.03-7jpp.ep1.3 - Satellite/xml-commons-1.3.03-7jpp.ep1.3.noarch.rpm
  Install: xml-commons-jaxp-apis.noarch 0:1.3.03-7jpp.ep1.3 - Satellite/xml-commons-jaxp-apis-1.3.03-7jpp.ep1.3.noarch.rpm
  Install: xml-commons-resolver.noarch 0:1.1-1jpp.ep1.1 - Satellite/xml-commons-resolver-1.1-1jpp.ep1.1.noarch.rpm
  Install: xom.noarch 0:1.0-2jpp.ep1.1 - Satellite/xom-1.0-2jpp.ep1.1.noarch.rpm
  Install: xpp2.noarch 0:2.1.10-4jpp.ep1.1 - Satellite/xpp2-2.1.10-4jpp.ep1.1.noarch.rpm
  Install: xpp3.noarch 0:1.1.3.4-1.o.2jpp.ep1.1 - Satellite/xpp3-1.1.3.4-1.o.2jpp.ep1.1.noarch.rpm
  Update: mod_perl.s390x 0:2.0.2-14.el4sat - Satellite/mod_perl-2.0.2-14.el4sat.s390x.rpm
Total download size: 1.2 G
Is this ok [y/N]: Traceback (most recent call last):
  File "/usr/bin/yum", line 7, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 146, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 638, in doTransaction
    if not self.userconfirm():
  File "/usr/share/yum-cli/output.py", line 244, in userconfirm
    choice = raw_input('Is this ok [y/N]: ')
EOFError: EOF when reading a line


Complete log-file is attached.
Comment 1 Sayli Karmarkar 2009-05-27 18:40:50 EDT
Created attachment 345687 [details]
rhn-installation.log
Comment 2 Sayli Karmarkar 2009-05-27 18:42:50 EDT
Same EOFError is seen even after I manually install all required packages and then run ./install.pl --answer-file=/root/answers.txt
Comment 3 Milan Zazrivec 2009-05-28 04:30:10 EDT
I'm pretty sure this problem is caused by the fact that you are using
a RHEL-4 system from RHTS with installed yum. Satellite installer will
never work correctly on RHEL-4 with yum, as this is not a standard
setup (RHEL-4 normally does not contain yum; it comes with up2date).
install.pl here detects yum and assumes it is on a RHEL-5 system, where
yum behaves differently (much more recent version).

For RHEL-4 systems reserved from RHTS you need to rpm -e yum first.
Comment 4 Brandon Perkins 2009-05-28 15:15:30 EDT
This bug as written isn't a bug.  However, I would like to morph this bug into a new bug saying that we need a secondary check against redhat-release.  There is nothing wrong with installing yum on RHEL-4... although it does go against the stated installation guide.  I would still like to see a secondary check added.
Comment 5 Sayli Karmarkar 2009-05-29 10:52:21 EDT
Milan,

Isn't yum coming into picture only when there are packages needed to be installed? Correct me if I am wrong. If already all packages needed are installed manually, why should we see error mentioned in comment# 2?

~SayliK 

(In reply to comment #3)
> I'm pretty sure this problem is caused by the fact that you are using
> a RHEL-4 system from RHTS with installed yum. Satellite installer will
> never work correctly on RHEL-4 with yum, as this is not a standard
> setup (RHEL-4 normally does not contain yum; it comes with up2date).
> install.pl here detects yum and assumes it is on a RHEL-5 system, where
> yum behaves differently (much more recent version).
> 
> For RHEL-4 systems reserved from RHTS you need to rpm -e yum first.
Comment 6 Devan Goodwin 2009-06-01 10:53:02 EDT
Sayli, was this an automated installation? If so, is yum being installed on the RHEL 4 RHTS systems a recent change? And more importantly is the script being used to automate the install prepared to offer input for the yum prompt? (it looks to me like the script is not designed to answer the question when yum asks if it should proceed with the install)

Note that yum is used to install the packages from the ISO, though I don't remember getting prompted y/n during a normal RHEL 5 install.

Investigating changing the logic to also check for redhat-release, and if on RHEL 4 just use up2date even if yum is present.
Comment 7 Devan Goodwin 2009-06-01 11:05:09 EDT
Actually when yum is called it offers the -y option, which should suppress the prompt. Sayli is there any chance you could post the version of yum installed on these RHEL 4 machines? I think that's probably why we're getting the prompt. (no -y option)
Comment 8 Devan Goodwin 2009-06-02 14:52:05 EDT
Ok logic has changed to check for yum as it did before, but if:

rpm -q --qf='%{VERSION}' redhat-release

Starts with a 4, we ignore yum and stick to up2date just the same.

spacewalk.git: 0530358fae431007a25697ec6210478033414502
satellite.git: 449a348a7b1fc42055d894ff1fa1fe2f74408b56
Comment 9 Sayli Karmarkar 2009-06-11 19:29:24 EDT
Here is what I am seeing:

[root@z204 satiso]# ./install.pl --answer-file=/root/answers.txt
* Starting the Red Hat Network Satellite installer.
* Loading answer file: /root/answers.txt.
* Performing pre-install checks.
* Pre-install checks complete.  Beginning installation.
* RHN Registration.
** Registration: System is already registered with RHN.  Not re-registering.
Warning: Found yum on RHEL 4, using up2date instead.
* Installing required packages.
The following packages from Red Hat Enterprise Linux that are not part
of the @base group have to be installed on this system for the installer
and the Satellite to operate correctly:
 
...
...
	perl-IO-String
	perl-Parse-Yapp
	perl-Time-HiRes
	tftp-server
	xorg-x11-deprecated-libs

** Checking if up2date is available ...
We can try to install the needed packages now, by running up2date -i.
Do you want to run this command now [y/N]? y
** Running rpm --import /usr/share/rhn/RPM-GPG-KEY
Installing packages. The log can be found in

	/var/log/rhn/rhn-installation.log

You can tail -f in another terminal to see the progress.
Running up2date --arch=s390x --arch=noarch -i PyXML alsa-lib apr apr-util compat-db distcache gd gd-devel gd-progs httpd httpd-suexec libaio mkisofs mod_python mod_ssl newt-perl perl-Archive-Tar perl-Compress-Zlib perl-DateManip perl-Digest-HMAC perl-Digest-SHA1 perl-IO-String perl-Parse-Yapp perl-Time-HiRes tftp-server xorg-x11-deprecated-libs
* Applying updates.
* Installing RHN packages.
Could not install RHN packages.  Most likely your system is not configured with the @Base package group.  See the RHN Satellite Server Installation Guide for more information about Software Requirements.  Exit value: 251.
Please examine /var/log/rhn/rhn-installation.log for more information.



/var/log/rhn/rhn-installation.log is attached. yum and up2date versions installed are: 
[root@z204 satiso]# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 4 (Nahant Update 7)
[root@z204 satiso]# rpm -q up2date
up2date-4.7.1-17.el4
[root@z204 satiso]# rpm -q yum
yum-2.2.2-1.rhts.EL4


So, Brandon and Devan, what do we expect to happen? As far as I understand 2 outcomes seem to be valid:
1. install should proceed without error, just running up2date instead of yum to install packages. 
2. error asking user to un-install yum or warning saying it is not a standard setup.
Comment 10 Sayli Karmarkar 2009-06-11 19:37:09 EDT
Created attachment 347496 [details]
new rhn-installation.log 

It seems like some files are conflicting with files from yum package.
Comment 11 Devan Goodwin 2009-06-11 21:27:57 EDT
Based on the above it looks like the new code properly decided to use up2date.

You're correct about yum conflicting with python-urlgrabber, which I believe is a new dependency for us, thus why we're just seeing this now. I think at one time urlgrabber was part of yum in RHEL 5 but was split out into it's own package.

At this point IMO there's not much we can do, yum on RHEL 4 is obviously not standard or supported and with this ticket we made some changes to attempt to accommodate it, but the package used in RHTS is already causing problems. 

Perhaps we could get a newer version of yum deployed automatically in RHTS but there's probably a reason they're using an older one. 

Otherwise I think we just have to rpm -e yum when testing Satellite installs on RHEL 4 RHTS systems.
Comment 12 Devan Goodwin 2009-06-11 21:31:36 EDT
Anyone know who to talk to in RHTS who might know more about why/how they use yum in the infrastructure on RHEL 4, and if they have any suggestions for this problem?
Comment 14 Sayli Karmarkar 2009-06-15 10:53:48 EDT
Yup. Removing yum helps and installation is completed without EOF error mentioned in the bug description. Moving to verified.

~SayliK
Comment 16 Garik Khachikyan 2009-06-15 11:36:18 EDT
Created attachment 347954 [details]
log with error using yum
Comment 19 Tomas Lestach 2009-08-20 08:12:12 EDT
Installation of Satellite-5.3.0-RHEL4-re20090819.0 on s390x with yum:

1.) installed
# rpm -q yum
yum-2.2.2-1.rhts.EL4

sat installation fails because of package conflict python-urlgrabber-2.9.8-0.3.el4 and yum-2.2.2-1.rhts.EL4

2.) uninstalled
# rpm -q yum
package yum is not installed

sat installation successful

Confirming that rhts yum disallows the sat installation on s390x/RHEL4.
Comment 20 Brandon Perkins 2009-09-10 16:37:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.