Bug 502995 - virt-manager virtual network wizard should not require an IP address
virt-manager virtual network wizard should not require an IP address
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 03:25 EDT by Peter Bieringer
Modified: 2010-03-16 13:20 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-24 14:57:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2009-05-28 03:25:30 EDT
Description of problem:
Setup of a new switch in GUI requires IPv4 address, but this should be optional because since new version, such interface is also working without IPv4.

Version-Release number of selected component (if applicable):
libvirt-0.6.2-11.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Setup new switch without IPv4 address

Actual results:
Does not work


Expected results:
Work

Note also that GUI does not reflect the real settings of current configured switches.

While config is 

# more /etc/libvirt/qemu/networks/IPv6internal.xml 
<network>
  <name>IPv6internal</name>
  <uuid>c6a01b49-73b2-61f0-5356-059ae90f5c5b</uuid>
  <bridge stp='on' forwardDelay='0' />
  <!--
  <ip address='192.168.100.1' netmask='255.255.255.0'>
    <dhcp>
      <range start='192.168.100.128' end='192.168.100.254' />
    </dhcp>
  </ip>
  -->
</network>

(note, IPv4 settings commented out), the GUI still shows this entries, looks like such information is stored a 2nd time on the box.
Comment 1 Mark McLoughlin 2009-05-28 03:39:42 EDT
which GUI? virt-manager?

Maybe a screenshot would help explain why you mean by "does not work"?
Comment 2 Peter Bieringer 2009-05-28 06:05:02 EDT
Yes, the virt-manager, you cannot leave the fields empty. Filling the IPv4 fields is mandatory. Perhaps it would be good to add a switch box "enable IPv4 DCHP" on this interface and if enabled, then IPv4 fields have to be filled, otherwise not.
Comment 3 Mark McLoughlin 2009-06-04 10:29:45 EDT
Okay, thanks - moving upstream since it's not a very common case

See also bug #501912
Comment 4 Cole Robinson 2009-09-24 14:57:10 EDT
Current upstream provides an option to disable DHCP when creating a new virtual network. Closing as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.