Bug 50302 - [IDE Problems] Installer crashes when transferring install image to hard drive
[IDE Problems] Installer crashes when transferring install image to hard drive
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 02:19 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 22:11:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-30 02:19:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)

Description of problem:
I have an Intell Penium II computer on which I have been running RedHat 6.1 and
Windows 2000 SE. I have two hard drives.
I decided to upgrade to RH7.1 but the installer crashed. I thought perhaps the
installer needed more disk space so I backed up /home, /etc, and /usr/local to
a FAT32 partition and then repartitioned both drives. I then installed RH7.1 from
scratch, but the installer froze just as the progress window for transferring install
image to h.d. appeared. I have 64Megs of RAM and 517Megs of Swap. I also
tried to get the RH6.1 installer to install the RH7.1 but it does not recognize the
RH7.1 cdroms.
I have now reinstalled the RH6.1 and would like to install RH7.1 to a new partition:
/dev/hda1 FAT32  Windows2000
/dev/hda2 ext2       /home
/dev/hdb1 FAT32 
/dev/hdb2 ext2      /           RH6.1
/dev/hdb5 ext2      /RH7.1/boot
/dev/hdb6 Swap    517Megs
/dev/hdb7 ext2      /RH7.1

But the RH7.1 installer always crashes just after a sliver of the progress window
for transferring install image to h.d. appears.

How reproducible:
Always

Steps to Reproduce:
1.Boot from RedHat7.1 CDROM
2.Choose Workstation or Custom or Upgrade
3.After selecting packages and formatting h.d. the installer
will freeze just after the progress window for transferring
install image to h.d. appears.
	

Actual Results:  The installer freezes (crashes).

Expected Results:  The installer should have begun installing all the packages
selected for the class of installation selected.

Additional info:
Comment 1 Brent Fox 2001-07-30 10:55:32 EDT
When the installer freezes, can you press <Ctrl><Alt><F4> and see if there are
any kernel error messages?
Comment 2 Need Real Name 2001-07-31 00:51:54 EDT
I pressed Ctrl-Alt-F4 as you suggested and although I could not write
fast enough to capture everything, I think I got what's important:

<7> ISO 9660 extensions RRIP_1991A
<7> Unable to identify CD ROM format
<6> Adding Swap
<4> 8 reg 439.600 Mb/sec
<4> 32 reg 244.800 Mb/sec
<4> pII_max 601.200 Mb/sec
<4> p5_max 629.200 Mb/sec
<4> hdc timeout waiting for DMA
<4> ide_dma_proc: chipset supported ide_dma_timeout function only: 14
<4> irq timeout: status=0xff { Busy}
<4> DMA disabled
<4> ATAPI reset timed-out, status=0xff
<4> reset timed-out, status=0xff
<4> status timeout: status=0xff { Busy}
<4> end_request: I/O error, dev 16:00 (hdc), sector 1035320

The last four lines just keep repeating as the CD ROM is silent.
I am able to read this CD in Windows and in RedHat 6.1
I could copy both RH7 install disks to the FAT32 partition: /dev/hdb1
and try installing from there. On the first disk there are some RPMS that
are in the RedHat directory rather than in the subdirectory RPMS. Should
I maintain the same organization and combine the RPMS from the RPMS
directories on both disks?
Comment 3 Matt Wilson 2001-08-06 15:16:05 EDT
try booting the installer with "linux ida=nodma".  If this works, send the
output of:

for I in /proc/ide/hd*; do echo $I; cat $I/model; done

Comment 4 Need Real Name 2001-08-08 22:57:22 EDT
Since I last commented, I decided to work around the cdrom problem by booting
into RedHat6.1 and
making an iso9660 image of the RH7.1 install CDs. I then booted from an
installatiion diskette for RH7.1 and was then able to finally install RH7.1
However, when I tried to install RPMS from the 
Powertools CD the GNORPM hung when trying to read the CD so the bug appears to
be with the 
kernel and not anaconda.
I then booted RH7.1 with your boot paramter ide=nodma and tried to install RPMS
from the 
Powertools CD, but the GNORPM hung with the same ATAPI reset timed out sys error
message.
Here is /proc/ide/hd*/model as you requested:
/proc/ide/hda
ST34342A
/proc/ide/hdb
IBM-DTLA-307015
/proc/ide/hdc
BCD 32X CD-ROM
Comment 5 Matt Wilson 2001-08-09 17:14:15 EDT
so, if I'm reading you right, ide=nodma didn't get rid of the timeouts, correct?
Comment 6 Need Real Name 2001-08-09 22:08:58 EDT
My apologies -- I must have goofed!  ide=nodma fixes the problem.
I've re-checked now several times the boot parameter ide=nodma when booting
RH7.1
and that seems to solve the problem of reading CDROMs. I've also re-checked
booting without
this parameter and find that the system then hangs when reading the CDROM.
Fortunately I can
shut the system down from another Virtual Terminal, but the system is unable to
successfully 
unmount /home and must recheck and fix the filesystem on reboot.
I guess the problem is now solved?  I was afraid I was going to have to attempt
to compile a newer 
version of the kernel.
Comment 7 Need Real Name 2001-08-09 22:10:57 EDT
My apologies -- I must have goofed!  ide=nodma fixes the problem.
I've re-checked now several times the boot parameter ide=nodma when booting
RH7.1
and that seems to solve the problem of reading CDROMs. I've also re-checked
booting without
this parameter and find that the system then hangs when reading the CDROM.
Fortunately I can
shut the system down from another Virtual Terminal, but the system is unable to
successfully 
unmount /home and must recheck and fix the filesystem on reboot.
I guess the problem is now solved?  I was afraid I was going to have to attempt
to compile a newer 
version of the kernel.
Comment 8 Arjan van de Ven 2001-08-10 04:47:16 EDT
ide=nodma is a reasonable workaround for the bad cdrom drive; I'll add it
to the list of known-bad cdromdrives so it'll be automatic in the future.

Thanks for the info.

Note You need to log in before you can comment on or make changes to this bug.