Bug 503049 - Boot F11/ppc and point to F11/i386 for install.img should present WARNING
Boot F11/ppc and point to F11/i386 for install.img should present WARNING
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 503458 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 10:52 EDT by James Laska
Modified: 2013-09-02 02:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-16 13:46:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-05-28 10:52:42 EDT
Description of problem:

Accidentally entering a i386 install.img URL, the installer doesn't fail gracefully.  

Version-Release number of selected component (if applicable):

anaconda-11.5.0.56

Steps to Reproduce:
1. Boot F11/ppc install media (boot.iso + askmethod, or just PXE)
2. Point to a F11/i386 installation source for install.img
  
Actual results:

Running anaconda 11.5.0.56, the Fedora system installer - please wait...
exec of anaconda failed: Exec format error
install exited abnormally [1/1] 
disabling swap...
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0 LOOP_CLR_FD failed: 6
	/proc done
	/dev/pts done
	/sys done
	/selinux done
sending termination signals...done
sending kill signals...done
you may safely reboot your system

Expected results:

Expected a warning screen that indicated the install.img is for another architecture?  But perhaps it doesn't work this way anymore?

Additional info:
Comment 1 Andy Lindeberg 2009-06-01 11:07:50 EDT
*** Bug 503458 has been marked as a duplicate of this bug. ***
Comment 2 Bug Zapper 2009-06-09 12:43:52 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Chris Lumens 2010-03-16 13:46:35 EDT
I don't think we have the information to make this determination until it's too late to do so.

Note You need to log in before you can comment on or make changes to this bug.